summaryrefslogtreecommitdiff
path: root/src/exchange-tools/Makefile.am
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2020-12-14 18:27:16 +0100
committerChristian Grothoff <christian@grothoff.org>2020-12-14 18:27:16 +0100
commit4a519078e803c8ff042833a2200c5b6a0297fbe7 (patch)
treee25c5ef53af137b949acaa6411f0d2917f0a3418 /src/exchange-tools/Makefile.am
parent45926ec067d82a1e4c2b28b5680baddc1e8dae0b (diff)
downloadexchange-4a519078e803c8ff042833a2200c5b6a0297fbe7.tar.gz
exchange-4a519078e803c8ff042833a2200c5b6a0297fbe7.tar.bz2
exchange-4a519078e803c8ff042833a2200c5b6a0297fbe7.zip
update generator scripts to use new -offline tools (WiP)
Diffstat (limited to 'src/exchange-tools/Makefile.am')
-rw-r--r--src/exchange-tools/Makefile.am36
1 files changed, 0 insertions, 36 deletions
diff --git a/src/exchange-tools/Makefile.am b/src/exchange-tools/Makefile.am
index 43954c446..82f4cbeb9 100644
--- a/src/exchange-tools/Makefile.am
+++ b/src/exchange-tools/Makefile.am
@@ -14,25 +14,9 @@ endif
bin_PROGRAMS = \
taler-auditor-offline \
- taler-exchange-keyup \
taler-exchange-offline \
- taler-exchange-wire \
taler-exchange-dbinit
-taler_exchange_keyup_SOURCES = \
- taler-exchange-keyup.c
-taler_exchange_keyup_LDADD = \
- $(LIBGCRYPT_LIBS) \
- $(top_builddir)/src/exchangedb/libtalerexchangedb.la \
- $(top_builddir)/src/bank-lib/libtalerbank.la \
- $(top_builddir)/src/json/libtalerjson.la \
- $(top_builddir)/src/pq/libtalerpq.la \
- $(top_builddir)/src/util/libtalerutil.la \
- -lgnunetutil \
- $(XLIB)
-taler_exchange_keyup_LDFLAGS = $(POSTGRESQL_LDFLAGS)
-
-
taler_exchange_offline_SOURCES = \
taler-exchange-offline.c
taler_exchange_offline_LDADD = \
@@ -46,7 +30,6 @@ taler_exchange_offline_LDADD = \
-lgnunetutil \
$(XLIB)
-
taler_auditor_offline_SOURCES = \
taler-auditor-offline.c
taler_auditor_offline_LDADD = \
@@ -60,21 +43,6 @@ taler_auditor_offline_LDADD = \
-lgnunetutil \
$(XLIB)
-
-taler_exchange_wire_SOURCES = \
- taler-exchange-wire.c
-taler_exchange_wire_LDADD = \
- $(LIBGCRYPT_LIBS) \
- $(top_builddir)/src/json/libtalerjson.la \
- $(top_builddir)/src/exchangedb/libtalerexchangedb.la \
- $(top_builddir)/src/bank-lib/libtalerbank.la \
- $(top_builddir)/src/util/libtalerutil.la \
- -lgnunetjson \
- -lgnunetutil \
- -ljansson \
- $(XLIB)
-taler_exchange_wire_LDFLAGS = $(POSTGRESQL_LDFLAGS)
-
taler_exchange_dbinit_SOURCES = \
taler-exchange-dbinit.c
taler_exchange_dbinit_LDADD = \
@@ -99,8 +67,4 @@ AM_TESTS_ENVIRONMENT=export TALER_PREFIX=$${TALER_PREFIX:-@libdir@};export PATH=
# Distribution
EXTRA_DIST = \
- test_taler_exchange_httpd_home/.local/share/taler/exchange/offline-keys/master.priv \
- test_taler_exchange_httpd.conf \
- key-helper.c \
- $(check_SCRIPTS) \
$(pkgcfg_DATA)