summaryrefslogtreecommitdiff
path: root/src/exchange-lib/Makefile.am
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2017-09-13 13:27:13 +0200
committerChristian Grothoff <christian@grothoff.org>2017-09-13 13:27:13 +0200
commite33d72683c9ea445fdca81f3d33c948b650f482f (patch)
tree15a7306eef1001c046d0ed1963f1cff80c5da615 /src/exchange-lib/Makefile.am
parent6d7645a99b523cb36d692de3e8d3bc80ddd8f21f (diff)
downloadexchange-e33d72683c9ea445fdca81f3d33c948b650f482f.tar.gz
exchange-e33d72683c9ea445fdca81f3d33c948b650f482f.tar.bz2
exchange-e33d72683c9ea445fdca81f3d33c948b650f482f.zip
skeleton for /keys cherry picking testcase
Diffstat (limited to 'src/exchange-lib/Makefile.am')
-rw-r--r--src/exchange-lib/Makefile.am14
1 files changed, 13 insertions, 1 deletions
diff --git a/src/exchange-lib/Makefile.am b/src/exchange-lib/Makefile.am
index d891d1d62..d6e068b73 100644
--- a/src/exchange-lib/Makefile.am
+++ b/src/exchange-lib/Makefile.am
@@ -45,7 +45,8 @@ endif
endif
check_PROGRAMS = \
- test_exchange_api
+ test_exchange_api \
+ test_exchange_api_keys_cherry_picking
AM_TESTS_ENVIRONMENT=export TALER_PREFIX=$${TALER_PREFIX:-@libdir@};export PATH=$${TALER_PREFIX:-@prefix@}/bin:$$PATH;
@@ -64,6 +65,17 @@ test_exchange_api_LDADD = \
-lgnunetutil \
-ljansson
+test_exchange_api_keys_cherry_picking_SOURCES = \
+ test_exchange_api_keys_cherry_picking.c
+test_exchange_api_keys_cherry_picking_LDADD = \
+ libtalerexchange.la \
+ $(LIBGCRYPT_LIBS) \
+ $(top_builddir)/src/json/libtalerjson.la \
+ $(top_builddir)/src/util/libtalerutil.la \
+ -lgnunetcurl \
+ -lgnunetutil \
+ -ljansson
+
EXTRA_DIST = \
test_exchange_api_home/.local/share/taler/exchange/offline-keys/master.priv \
test_exchange_api_home/.config/taler/test.json \