summaryrefslogtreecommitdiff
path: root/src/exchange-lib/Makefile.am
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2018-09-15 22:20:07 +0200
committerChristian Grothoff <christian@grothoff.org>2018-09-15 22:20:07 +0200
commit528faeab81ba240329140eb1587ccc542736c1dc (patch)
tree639283b45f05dcd7ad9e2e5c89a28cf3f9dbefd8 /src/exchange-lib/Makefile.am
parent46e4ea696cdba772ad5d6f8d79cf2e6586ef9979 (diff)
downloadexchange-528faeab81ba240329140eb1587ccc542736c1dc.tar.gz
exchange-528faeab81ba240329140eb1587ccc542736c1dc.tar.bz2
exchange-528faeab81ba240329140eb1587ccc542736c1dc.zip
fix #5315, including more testing
Diffstat (limited to 'src/exchange-lib/Makefile.am')
-rw-r--r--src/exchange-lib/Makefile.am29
1 files changed, 2 insertions, 27 deletions
diff --git a/src/exchange-lib/Makefile.am b/src/exchange-lib/Makefile.am
index 9dbd2256c..8ac43ea8c 100644
--- a/src/exchange-lib/Makefile.am
+++ b/src/exchange-lib/Makefile.am
@@ -48,6 +48,7 @@ libtalertesting_la_SOURCES = \
testing_api_cmd_refund.c \
testing_api_cmd_status.c \
testing_api_cmd_deposit.c \
+ testing_api_cmd_sleep.c \
testing_api_cmd_refresh.c \
testing_api_cmd_track.c \
testing_api_cmd_bank_check.c \
@@ -95,9 +96,7 @@ endif
check_PROGRAMS = \
test_exchange_api_keys_cherry_picking_new \
- test_exchange_api_new \
- test_exchange_api_keys_cherry_picking \
- test_exchange_api
+ test_exchange_api_new
if HAVE_TWISTER
check_PROGRAMS += \
@@ -126,19 +125,6 @@ AM_TESTS_ENVIRONMENT=export TALER_PREFIX=$${TALER_PREFIX:-@libdir@};export PATH=
TESTS = \
$(check_PROGRAMS)
-test_exchange_api_SOURCES = \
- test_exchange_api.c
-test_exchange_api_LDADD = \
- libtalerexchange.la \
- $(LIBGCRYPT_LIBS) \
- $(top_builddir)/src/bank-lib/libtalerfakebank.la \
- $(top_builddir)/src/bank-lib/libtalerbank.la \
- $(top_builddir)/src/json/libtalerjson.la \
- $(top_builddir)/src/util/libtalerutil.la \
- -lgnunetcurl \
- -lgnunetutil \
- -ljansson
-
test_exchange_api_new_SOURCES = \
test_exchange_api_new.c
test_exchange_api_new_LDADD = \
@@ -166,17 +152,6 @@ test_exchange_api_keys_cherry_picking_new_LDADD = \
-lgnunetutil \
-ljansson
-test_exchange_api_keys_cherry_picking_SOURCES = \
- test_exchange_api_keys_cherry_picking.c
-test_exchange_api_keys_cherry_picking_LDADD = \
- libtalerexchange.la \
- $(LIBGCRYPT_LIBS) \
- $(top_builddir)/src/json/libtalerjson.la \
- $(top_builddir)/src/util/libtalerutil.la \
- -lgnunetcurl \
- -lgnunetutil \
- -ljansson
-
EXTRA_DIST = \
test_exchange_api_home/.local/share/taler/exchange/offline-keys/master.priv \
test_exchange_api_home/.config/taler/test.json \