summaryrefslogtreecommitdiff
path: root/src/auditordb/Makefile.am
diff options
context:
space:
mode:
authortg(x) <*@tg-x.net>2016-11-04 00:37:47 +0100
committertg(x) <*@tg-x.net>2016-11-04 00:37:47 +0100
commit9ad83ae9bf74a9987fa957f544c7c6d8ee4af193 (patch)
tree5c9a1cc11f1f8ca589c66324ffbeaeea4a5f48e7 /src/auditordb/Makefile.am
parent59fa9d8255562b47f98cc55db066d50b9075fed7 (diff)
downloadexchange-9ad83ae9bf74a9987fa957f544c7c6d8ee4af193.tar.gz
exchange-9ad83ae9bf74a9987fa957f544c7c6d8ee4af193.tar.bz2
exchange-9ad83ae9bf74a9987fa957f544c7c6d8ee4af193.zip
auditordb test
Diffstat (limited to 'src/auditordb/Makefile.am')
-rw-r--r--src/auditordb/Makefile.am23
1 files changed, 20 insertions, 3 deletions
diff --git a/src/auditordb/Makefile.am b/src/auditordb/Makefile.am
index e8ec40272..640f95f25 100644
--- a/src/auditordb/Makefile.am
+++ b/src/auditordb/Makefile.am
@@ -12,7 +12,8 @@ pkgcfg_DATA = \
auditordb-postgres.conf
EXTRA_DIST = \
- auditordb-postgres.conf
+ auditordb-postgres.conf \
+ test-auditor-db-postgres.conf
plugindir = $(libdir)/taler
@@ -49,5 +50,21 @@ libtalerauditordb_la_LDFLAGS = \
-no-undefined
-EXTRA_test_auditordb_postgres_DEPENDENCIES = \
- libtaler_plugin_auditordb_postgres.la
+#EXTRA_test_auditordb_postgres_DEPENDENCIES = \
+# libtaler_plugin_auditordb_postgres.la
+
+
+check_PROGRAMS = \
+ test-auditordb-postgres
+
+AM_TESTS_ENVIRONMENT=export TALER_PREFIX=$${TALER_PREFIX:-@libdir@};export PATH=$${TALER_PREFIX:-@prefix@}/bin:$$PATH;
+TESTS = \
+ test-auditordb-postgres
+
+test_auditordb_postgres_SOURCES = \
+ test_auditordb.c
+test_auditordb_postgres_LDADD = \
+ libtalerauditordb.la \
+ $(top_srcdir)/src/pq/libtalerpq.la \
+ $(top_srcdir)/src/util/libtalerutil.la \
+ -lgnunetutil