summaryrefslogtreecommitdiff
path: root/src/auditor-lib/Makefile.am
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2018-10-22 16:00:06 +0200
committerChristian Grothoff <christian@grothoff.org>2018-10-22 16:00:06 +0200
commite83964badb5c266992f5b1312b31aa6a14d392e5 (patch)
treed4cd42532dd22cf1f215fd3dc05c5f29523b71ab /src/auditor-lib/Makefile.am
parent8eda33bbe8ae220c598ab0d8342f732e002c6067 (diff)
downloadexchange-e83964badb5c266992f5b1312b31aa6a14d392e5.tar.gz
exchange-e83964badb5c266992f5b1312b31aa6a14d392e5.tar.bz2
exchange-e83964badb5c266992f5b1312b31aa6a14d392e5.zip
skeleton for libtalerauditor
Diffstat (limited to 'src/auditor-lib/Makefile.am')
-rw-r--r--src/auditor-lib/Makefile.am36
1 files changed, 36 insertions, 0 deletions
diff --git a/src/auditor-lib/Makefile.am b/src/auditor-lib/Makefile.am
new file mode 100644
index 000000000..de2399961
--- /dev/null
+++ b/src/auditor-lib/Makefile.am
@@ -0,0 +1,36 @@
+# This Makefile.am is in the public domain
+AM_CPPFLAGS = -I$(top_srcdir)/src/include
+
+if USE_COVERAGE
+ AM_CFLAGS = --coverage -O0
+ XLIB = -lgcov
+endif
+
+lib_LTLIBRARIES = \
+ libtalerauditor
+
+libtalerauditor_la_LDFLAGS = \
+ -version-info 0:0:0 \
+ -no-undefined
+libtalerauditor_la_SOURCES = \
+ curl_defaults.c \
+ auditor_api_common.c \
+ auditor_api_handle.c auditor_api_handle.h \
+ auditor_api_deposit_confirmation.c
+libtalerauditor_la_LIBADD = \
+ $(top_builddir)/src/json/libtalerjson.la \
+ $(top_builddir)/src/util/libtalerutil.la \
+ -lgnunetcurl \
+ -lgnunetjson \
+ -lgnunetutil \
+ -ljansson \
+ $(XLIB)
+
+if HAVE_LIBCURL
+libtalerauditor_la_LIBADD += -lcurl
+else
+if HAVE_LIBGNURL
+libtalerauditor_la_LIBADD += -lgnurl
+endif
+endif
+