summaryrefslogtreecommitdiff
path: root/src/auditor-lib/Makefile.am
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2018-11-10 13:58:02 +0100
committerChristian Grothoff <christian@grothoff.org>2018-11-10 13:58:02 +0100
commit42a21ffc8ef36a141db2a7c57a20e70747028524 (patch)
treeacbcaa036e3160703628dc93d577c50b8060c693 /src/auditor-lib/Makefile.am
parentac850bfcd2d41a195520835369c2c9056aed1141 (diff)
downloadexchange-42a21ffc8ef36a141db2a7c57a20e70747028524.tar.gz
exchange-42a21ffc8ef36a141db2a7c57a20e70747028524.tar.bz2
exchange-42a21ffc8ef36a141db2a7c57a20e70747028524.zip
add skeleton for auditor httpd tests
Diffstat (limited to 'src/auditor-lib/Makefile.am')
-rw-r--r--src/auditor-lib/Makefile.am51
1 files changed, 50 insertions, 1 deletions
diff --git a/src/auditor-lib/Makefile.am b/src/auditor-lib/Makefile.am
index 1d3810fd5..988d352fa 100644
--- a/src/auditor-lib/Makefile.am
+++ b/src/auditor-lib/Makefile.am
@@ -7,7 +7,8 @@ if USE_COVERAGE
endif
lib_LTLIBRARIES = \
- libtalerauditor.la
+ libtalerauditor.la \
+ libtalerauditortesting.la
libtalerauditor_la_LDFLAGS = \
-version-info 0:0:0 \
@@ -33,3 +34,51 @@ if HAVE_LIBGNURL
libtalerauditor_la_LIBADD += -lgnurl
endif
endif
+
+
+libtalerauditortesting_la_LDFLAGS = \
+ -version-info 0:0:0 \
+ -no-undefined
+libtalerauditortesting_la_SOURCES = \
+ testing_auditor_api_helpers.c
+libtalerauditortesting_la_LIBADD = \
+ libtalerauditor.la \
+ $(top_builddir)/src/exchange-lib/libtalerexchange.la \
+ $(top_builddir)/src/exchange-lib/libtalertesting.la \
+ $(top_builddir)/src/wire/libtalerwire.la \
+ $(top_builddir)/src/json/libtalerjson.la \
+ $(top_builddir)/src/util/libtalerutil.la \
+ -lgnunetcurl \
+ -lgnunetjson \
+ -lgnunetutil \
+ -ljansson \
+ $(XLIB)
+
+
+check_PROGRAMS = \
+ test_auditor_api
+
+AM_TESTS_ENVIRONMENT=export TALER_PREFIX=$${TALER_PREFIX:-@libdir@};export PATH=$${TALER_PREFIX:-@prefix@}/bin:$$PATH;
+
+TESTS = \
+ $(check_PROGRAMS)
+
+test_auditor_api_SOURCES = \
+ test_auditor_api.c
+test_auditor_api_LDADD = \
+ libtalerauditortesting.la \
+ libtalerauditor.la \
+ $(top_builddir)/src/exchange-lib/libtalertesting.la \
+ $(top_builddir)/src/exchange-lib/libtalerexchange.la \
+ $(LIBGCRYPT_LIBS) \
+ $(top_builddir)/src/bank-lib/libtalerfakebank.la \
+ $(top_builddir)/src/bank-lib/libtalerbank.la \
+ $(top_builddir)/src/json/libtalerjson.la \
+ $(top_builddir)/src/util/libtalerutil.la \
+ -lgnunetcurl \
+ -lgnunetutil \
+ -ljansson
+
+
+EXTRA_DIST = \
+ test_auditor_api.conf