summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2016-04-15 15:00:26 +0200
committerChristian Grothoff <christian@grothoff.org>2016-04-15 15:00:26 +0200
commit74e237164ce7958c19467ad440e45576c4425570 (patch)
treee5156b7197cbb76ad0b0d617d9a04eeb2c08ea48 /src/Makefile.am
parentebf049a8c2d982e723fe67dbff64e1eea14d8247 (diff)
parent3098c0a9e0b18a436e484ef693cdebeb16d4c131 (diff)
downloadexchange-74e237164ce7958c19467ad440e45576c4425570.tar.gz
exchange-74e237164ce7958c19467ad440e45576c4425570.tar.bz2
exchange-74e237164ce7958c19467ad440e45576c4425570.zip
Merge branch 'master' of ssh://taler.net:/var/git/exchange
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am14
1 files changed, 11 insertions, 3 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index ac839d52a..6e0fb2049 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -3,16 +3,24 @@ AM_CPPFLAGS = -I$(top_srcdir)/src/include
if HAVE_POSTGRESQL
PQ_DIR = pq
endif
+if HAVE_LIBCURL
+ BANK_LIB = bank-lib
+else
+if HAVE_LIBGNURL
+ BANK_LIB = bank-lib
+endif
+endif
+
if WALLET_ONLY
SUBDIRS = include util
else
-SUBDIRS = include util $(PQ_DIR) bank-lib wire mintdb mint mint-tools
+SUBDIRS = include util json $(PQ_DIR) $(BANK_LIB) wire exchangedb exchange exchange-tools
if HAVE_LIBCURL
- SUBDIRS += mint-lib
+ SUBDIRS += exchange-lib
else
if HAVE_LIBGNURL
- SUBDIRS += mint-lib
+ SUBDIRS += exchange-lib
endif
endif