summaryrefslogtreecommitdiff
path: root/doc/doxygen/Makefile.am
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2018-11-25 15:54:45 +0100
committerChristian Grothoff <christian@grothoff.org>2018-11-25 15:54:45 +0100
commitabf640c97b5b8137ff6029132772f2a390f93b11 (patch)
tree83f8da70982daea590e839d3e92dc5071e4bfd88 /doc/doxygen/Makefile.am
parentf22401750505d281a092034342058fc588b62ea0 (diff)
downloadexchange-abf640c97b5b8137ff6029132772f2a390f93b11.tar.gz
exchange-abf640c97b5b8137ff6029132772f2a390f93b11.tar.bz2
exchange-abf640c97b5b8137ff6029132772f2a390f93b11.zip
doxygen for exchange'
Diffstat (limited to 'doc/doxygen/Makefile.am')
-rw-r--r--doc/doxygen/Makefile.am18
1 files changed, 18 insertions, 0 deletions
diff --git a/doc/doxygen/Makefile.am b/doc/doxygen/Makefile.am
new file mode 100644
index 000000000..cde28de43
--- /dev/null
+++ b/doc/doxygen/Makefile.am
@@ -0,0 +1,18 @@
+# This Makefile.am is in the public domain
+all:
+ @echo -e \
+"Generate documentation:\n" \
+"\tmake full - full documentation with dependency graphs (slow)\n" \
+"\tmake fast - fast mode without dependency graphs"
+
+full: taler.doxy
+ doxygen $<
+
+fast: taler.doxy
+ sed 's/\(HAVE_DOT.*=\).*/\1 NO/' $< | doxygen -
+
+clean:
+ rm -rf html
+
+EXTRA_DIST = \
+ taler.doxy