summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorChristian Grothoff <grothoff@gnunet.org>2023-12-05 22:45:43 +0900
committerChristian Grothoff <grothoff@gnunet.org>2023-12-05 22:45:43 +0900
commit4b4b0b9c48cb501e0afbe2e940135675f5d615a6 (patch)
tree94c2ec3e150501a57d9c0ea044716816ac037e46 /debian
parentefafdf44d91779d89ebd86c3d0454493bc2603f4 (diff)
downloadexchange-4b4b0b9c48cb501e0afbe2e940135675f5d615a6.tar.gz
exchange-4b4b0b9c48cb501e0afbe2e940135675f5d615a6.tar.bz2
exchange-4b4b0b9c48cb501e0afbe2e940135675f5d615a6.zip
-fix /etc/taler/taler.conf permissions in debian package, bump required GNUnet version
Diffstat (limited to 'debian')
-rw-r--r--debian/control4
-rw-r--r--debian/libtalerexchange.postinst28
2 files changed, 30 insertions, 2 deletions
diff --git a/debian/control b/debian/control
index 80ebebe69..fe80f9cf8 100644
--- a/debian/control
+++ b/debian/control
@@ -10,7 +10,7 @@ Build-Depends:
gcc-12,
debhelper-compat (= 12),
gettext,
- libgnunet-dev (>=0.20),
+ libgnunet-dev (>=0.21),
libcurl4-gnutls-dev (>=7.35.0) | libcurl4-openssl-dev (>= 7.35.0),
libgcrypt20-dev (>=1.8),
libgnutls28-dev (>=3.2.12),
@@ -146,7 +146,7 @@ Section: libdevel
Architecture: any
Depends:
libtalerexchange (= ${binary:Version}),
- libgnunet-dev (>=0.20),
+ libgnunet-dev (>=0.21),
libgcrypt20-dev (>=1.8),
libmicrohttpd-dev (>=0.9.71),
${misc:Depends},
diff --git a/debian/libtalerexchange.postinst b/debian/libtalerexchange.postinst
new file mode 100644
index 000000000..40b4be061
--- /dev/null
+++ b/debian/libtalerexchange.postinst
@@ -0,0 +1,28 @@
+#!/bin/bash
+
+set -e
+
+. /usr/share/debconf/confmodule
+
+case "${1}" in
+configure)
+
+ if ! dpkg-statoverride --list /etc/taler/taler.conf >/dev/null 2>&1; then
+ dpkg-statoverride --add --update \
+ root root 644 \
+ /etc/taler/taler.conf
+ fi
+
+ ;;
+
+abort-upgrade | abort-remove | abort-deconfigure) ;;
+
+*)
+ echo "postinst called with unknown argument \`${1}'" >&2
+ exit 1
+ ;;
+esac
+
+#DEBHELPER#
+
+exit 0