summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2020-12-31 22:22:19 +0100
committerChristian Grothoff <christian@grothoff.org>2020-12-31 22:22:19 +0100
commitf82488c060ea980b1da69a022f26658526575547 (patch)
tree0e6c172171075dc4e2c871aa5454ec37d3314b84 /configure.ac
parent0bffea1f67067f56638a36d0b7db30af09d929ac (diff)
downloadexchange-f82488c060ea980b1da69a022f26658526575547.tar.gz
exchange-f82488c060ea980b1da69a022f26658526575547.tar.bz2
exchange-f82488c060ea980b1da69a022f26658526575547.zip
add missing linker options, bonus fun
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 91816ca8a..9a3d63bbb 100644
--- a/configure.ac
+++ b/configure.ac
@@ -211,9 +211,9 @@ AS_IF([test "$gnurl" = 1],
[AM_CONDITIONAL(HAVE_LIBGNURL, false)
AC_DEFINE([HAVE_LIBGNURL],[0],[Lacking libgnurl])
AM_CONDITIONAL(HAVE_LIBCURL, true)
- AC_DEFINE([HAVE_LIBCURL],[1],[Have libcurl])],
- [LIBGNURLCURL_LIBS="-lcurl"]
- [AC_MSG_ERROR([WARNING: No libgnurl/libcurl, taler-bank support will not be compiled])])])
+ AC_DEFINE([HAVE_LIBCURL],[1],[Have libcurl])
+ [LIBGNURLCURL_LIBS="-lcurl"]],
+ [AC_MSG_ERROR([FATAL: No libgnurl/libcurl])])])
AC_SUBST([LIBGNURLCURL_LIBS])