summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2024-01-08 15:28:25 +0100
committerChristian Grothoff <christian@grothoff.org>2024-01-08 15:28:25 +0100
commitbc1e8787e5954ca2d433f495bee336e7b57c1654 (patch)
treee1a806851cbb7eb7ccbe688942329fc0691dfe97 /configure.ac
parentb26bab5ed8069ac79dda032a5167363ebb4727e7 (diff)
downloadexchange-bc1e8787e5954ca2d433f495bee336e7b57c1654.tar.gz
exchange-bc1e8787e5954ca2d433f495bee336e7b57c1654.tar.bz2
exchange-bc1e8787e5954ca2d433f495bee336e7b57c1654.zip
fix long-polling on purses GET with purse refund event
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 5f211c4b2..8c7769a83 100644
--- a/configure.ac
+++ b/configure.ac
@@ -310,11 +310,11 @@ AS_CASE([$with_gnunet],
CPPFLAGS="-I$with_gnunet/include ${CPPFLAGS}"])
CPPFLAGS="${CPPFLAGS} ${POSTGRESQL_CPPFLAGS}"
AC_CHECK_HEADERS([gnunet/gnunet_pq_lib.h],
- [AC_CHECK_LIB([gnunetpq], [GNUNET_PQ_result_spec_array_string], libgnunetpq=1)])
+ [AC_CHECK_LIB([gnunetpq], [GNUNET_PQ_get_event_notify_channel], libgnunetpq=1)])
AS_IF([test $libgnunetpq != 1],
[AC_MSG_ERROR([[
***
-*** You need libgnunetpq version >= 4.0.0 to build this program.
+*** You need libgnunetpq version >= 5:0:0 to build this program.
*** Make sure you have Postgres installed while
*** building GNUnet (and that your GNUnet version
*** is recent!)