summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2022-12-08 14:20:22 +0100
committerChristian Grothoff <christian@grothoff.org>2022-12-08 14:20:22 +0100
commit329b7692ea4b09d9fb1399ad38af87b6e7486f38 (patch)
treeb443ef51c399bc6feed64f470dd0941dcf421444 /configure.ac
parent87198f124c989d014adc9a2bae5098cf80555d62 (diff)
downloadexchange-329b7692ea4b09d9fb1399ad38af87b6e7486f38.tar.gz
exchange-329b7692ea4b09d9fb1399ad38af87b6e7486f38.tar.bz2
exchange-329b7692ea4b09d9fb1399ad38af87b6e7486f38.zip
-improve postgres check
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 12 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index c80c2e8f0..bbbce187f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -246,9 +246,18 @@ LIBS=$LIBS_SAVE
# test for postgres
AX_LIB_POSTGRESQL([13.0])
-AS_IF([test "x$found_postgresql" = "xyes"],[postgres=true])
-
-AM_CONDITIONAL(HAVE_POSTGRESQL, test x$postgres = xtrue)
+AS_IF([test "x$found_postgresql" = "xyes"],
+ [SAVE_CPPFLAGS="$CPPFLAGS"
+ CPPFLAGS="$POSTGRES_CPPFLAGS $CPPFLAGS"
+ AC_CHECK_HEADERS([libpq-fe.h], [postgres=1], [postgres=0])])
+AS_IF([test "x$postgres" != "x1"],
+ [AC_MSG_ERROR([[
+***
+*** You need libpq(-dev) >= 13.0 to build this program.
+*** ]])])
+AM_CONDITIONAL([HAVE_POSTGRESQL], [test "x$postgres" = "x1"])
+AC_DEFINE_UNQUOTED([HAVE_POSTGRESQL], [$postgres],
+ [Define to 1 if Postgres is available])
# Check for GNUnet's libgnunetpq.
libgnunetpq=0