summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2016-04-15 15:00:26 +0200
committerChristian Grothoff <christian@grothoff.org>2016-04-15 15:00:26 +0200
commit74e237164ce7958c19467ad440e45576c4425570 (patch)
treee5156b7197cbb76ad0b0d617d9a04eeb2c08ea48 /Makefile.am
parentebf049a8c2d982e723fe67dbff64e1eea14d8247 (diff)
parent3098c0a9e0b18a436e484ef693cdebeb16d4c131 (diff)
downloadexchange-74e237164ce7958c19467ad440e45576c4425570.tar.gz
exchange-74e237164ce7958c19467ad440e45576c4425570.tar.bz2
exchange-74e237164ce7958c19467ad440e45576c4425570.zip
Merge branch 'master' of ssh://taler.net:/var/git/exchange
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 7 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index cbf014371..f14372f52 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -2,3 +2,10 @@
AM_CPPFLAGS = -I$(top_srcdir)/src/include
SUBDIRS = src doc
ACLOCAL_AMFLAGS = -I m4
+EXTRA_DIST = AUTHORS
+
+app:
+ mkdir -p $(PACKAGE)-$(VERSION)-app
+ tar cf - configure.ac AUTHORS README doc/*.1 doc/*.5 doc/Makefile.am Makefile.am `find src/ -name "*.c" -o -name "*.h" -o -name Makefile.am` | (cd $(PACKAGE)-$(VERSION)-app ; tar xf -)
+ tar cf $(PACKAGE)-$(VERSION)-app.tgz $(PACKAGE)-$(VERSION)-app
+ rm -rf $(PACKAGE)-$(VERSION)-app