summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMarcello Stanisci <stanisci.m@gmail.com>2019-03-27 18:47:16 +0100
committerMarcello Stanisci <stanisci.m@gmail.com>2019-03-27 18:47:16 +0100
commitaa6229dd85dfe0684dbfbbcde7e3148af8f2f7d8 (patch)
tree59425d0dd7ef20b56fc9ac8eeb017f4ec5b43dac /configure.ac
parent688a79977b797b137694c3887bca2672502ab482 (diff)
downloaddonations-aa6229dd85dfe0684dbfbbcde7e3148af8f2f7d8.tar.gz
donations-aa6229dd85dfe0684dbfbbcde7e3148af8f2f7d8.tar.bz2
donations-aa6229dd85dfe0684dbfbbcde7e3148af8f2f7d8.zip
fix pip3
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 8852d84..c7440be 100644
--- a/configure.ac
+++ b/configure.ac
@@ -31,6 +31,16 @@ AC_MSG_RESULT([$VERSION])
AX_COMPARE_VERSION([$VERSION],[lt],[6.0], [AC_MSG_ERROR([Please install pip3>=6.0])])
+# On Debian systems, we may need to pass "--system" to pip3 to get
+# to the desired installation target directory
+pip3 install --help | grep '\-\-system' >> /dev/null
+if test $? -ne 0;
+then
+ DEBIAN_PIP3_SYSTEM=""
+else
+ DEBIAN_PIP3_SYSTEM="--system"
+fi
+AC_SUBST(DEBIAN_PIP3_SYSTEM)
#
# Check for tsc