summaryrefslogtreecommitdiff
path: root/taler-merchant-manual.rst
diff options
context:
space:
mode:
authorThien-Thi Nguyen <ttn@gnuvola.org>2020-12-03 04:50:28 -0500
committerThien-Thi Nguyen <ttn@gnuvola.org>2020-12-03 04:50:28 -0500
commit53bd9da73464b10b6dbbc6f5d8abb52083769eed (patch)
treed30dda802322e1c803c84dcaeb804b7e05aaf21d /taler-merchant-manual.rst
parent3651e04712aa50187e12202a9f7c192f82471338 (diff)
downloaddocs-53bd9da73464b10b6dbbc6f5d8abb52083769eed.tar.gz
docs-53bd9da73464b10b6dbbc6f5d8abb52083769eed.tar.bz2
docs-53bd9da73464b10b6dbbc6f5d8abb52083769eed.zip
touch up §3.3.2 "Installing Taler on Debian GNU/Linux"
- add two index entries - mention that Jessie, too, is too old - rework Jessie instructions for Stretch, instead - fix bug: use ‘libargon2-0-dev’ for Stretch - remove autoconf, automake, autopoint, libtool (two instances) - update to ‘postgresql-9.6’ (two instances) - add Note re ‘libargon2-0-dev’ vs ‘libargon2-dev’
Diffstat (limited to 'taler-merchant-manual.rst')
-rw-r--r--taler-merchant-manual.rst24
1 files changed, 11 insertions, 13 deletions
diff --git a/taler-merchant-manual.rst b/taler-merchant-manual.rst
index a788eaf..5b64afb 100644
--- a/taler-merchant-manual.rst
+++ b/taler-merchant-manual.rst
@@ -424,30 +424,29 @@ Installing Taler on Debian GNU/Linux
------------------------------------
.. index:: Wheezy
+.. index:: Jessie
+.. index:: Stretch
.. index:: Debian
Debian wheezy is too old and lacks most of the packages required.
+Debian jessie is better, but still lacks PostgreSQL 9.6.
-On Debian jessie, only GNU libmicrohttpd needs to be compiled from
-source. To install dependencies on Debian jesse, run the following
+On Debian stretch, only GNU libmicrohttpd needs to be compiled from
+source. To install dependencies on Debian stretch, run the following
commands:
::
# apt-get install \
- autoconf \
- automake \
- autopoint \
- libtool \
libltdl-dev \
libunistring-dev \
libsodium-dev \
- libargon2-dev \
+ libargon2-0-dev \
libcurl4-gnutls-dev \
libgcrypt20-dev \
libjansson-dev \
libpq-dev \
- postgresql-9.4
+ postgresql-9.6
# wget https://ftp.gnu.org/gnu/libmicrohttpd/libmicrohttpd-latest.tar.gz
# wget https://ftp.gnu.org/gnu/libmicrohttpd/libmicrohttpd-latest.tar.gz.sig
# gpg -v libmicrohttpd-latest.tar.gz # Should show signed by 939E6BE1E29FC3CC
@@ -461,10 +460,6 @@ For more recent versions of Debian, you should instead run:
::
# apt-get install \
- autoconf \
- automake \
- autopoint \
- libtool \
libltdl-dev \
libunistring-dev \
libsodium-dev \
@@ -473,9 +468,12 @@ For more recent versions of Debian, you should instead run:
libgcrypt20-dev \
libjansson-dev \
libpq-dev \
- postgresql-9.5 \
+ postgresql-9.6 \
libmicrohttpd-dev
+Note that stretch requires ``libargon2-0-dev``,
+while later versions of Debian require ``libargon2-dev``.
+
For the rest of the installation, follow the generic installation
instructions starting with the installation of libgnunetutil. Note that
if you used the Debian wheezy instructions above, you need to pass