summaryrefslogtreecommitdiff
path: root/btc-wire/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'btc-wire/Cargo.toml')
-rw-r--r--btc-wire/Cargo.toml8
1 files changed, 4 insertions, 4 deletions
diff --git a/btc-wire/Cargo.toml b/btc-wire/Cargo.toml
index d6a120c..5955a66 100644
--- a/btc-wire/Cargo.toml
+++ b/btc-wire/Cargo.toml
@@ -3,7 +3,7 @@ name = "btc-wire"
version = "0.1.0"
edition = "2021"
license = "AGPL-3.0-or-later"
-rust-version = "1.63.0"
+rust-version = "1.72.1"
[features]
# Enable random failures
@@ -11,13 +11,13 @@ fail = []
[dependencies]
# Typed bitcoin rpc types
-bitcoin = { version = "0.30.1", features = [
+bitcoin = { version = "0.31.0", features = [
"std",
"serde",
], default-features = false }
# Cli args parser
clap = { version = "4.4.6", features = ["derive"] }
-clap_lex = "0.5.1"
+clap_lex = "0.6.0"
# Bech32 encoding and decoding
bech32 = "0.9.1"
# Serialization library
@@ -30,7 +30,7 @@ data-encoding = "2.4.0"
# Common lib
common = { path = "../common" }
# Ini parser
-rust-ini = "0.19.0"
+rust-ini = "0.20.0"
# Hexadecimal encoding
hex = { package = "const-hex", version = "1.9.1" }