summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorMarcello Stanisci <stanisci.m@gmail.com>2017-11-24 19:50:47 +0100
committerMarcello Stanisci <stanisci.m@gmail.com>2017-11-24 19:50:47 +0100
commita4a840db8846d1d23fb60ae4a68dde0bc2211cd7 (patch)
tree9281b3b305b73169f96b71c72c2ed18667823b80 /setup.py
parent32cabbe0128f0a74829103ce707d9c4e441251b6 (diff)
downloadbackoffice-a4a840db8846d1d23fb60ae4a68dde0bc2211cd7.tar.gz
backoffice-a4a840db8846d1d23fb60ae4a68dde0bc2211cd7.tar.bz2
backoffice-a4a840db8846d1d23fb60ae4a68dde0bc2211cd7.zip
setuptools
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py27
1 files changed, 27 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100755
index 0000000..0f4fdf5
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,27 @@
+from setuptools import setup, find_packages
+
+setup(name='talerblog',
+ version='0.0',
+ description='Example blog site for GNU Taler',
+ url='git://taler.net/blog',
+ author='Marcello Stanisci',
+ author_email='stanisci.m@gmail.com',
+ license='GPL',
+ packages=find_packages(),
+ install_requires=["Flask>=0.10"],
+ package_data={
+ '':[
+ "survey/templates/*.html",
+ "survey/static/*.svg",
+ "survey/static/*.css",
+ "survey/static/*.js",
+ "survey/static/*.js.tar.gz",
+ "survey/static/web-common/*.png",
+ "survey/static/web-common/*.css",
+ "survey/static/web-common/*.js",
+ "survey/static/web-common/*.js.tar.gz",
+ "survey/static/web-common/*.html",
+ ]
+ },
+ scripts=['taler-merchant-blog'],
+ zip_safe=False)