summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMarcello Stanisci <stanisci.m@gmail.com>2018-06-04 22:42:30 +0200
committerMarcello Stanisci <stanisci.m@gmail.com>2018-06-04 22:42:30 +0200
commit188b21026024cd79a2b6942f5d9d309fd7640371 (patch)
tree0acf97e3b6042ed4b5b0a1cb1093784df21b6a97 /configure.ac
parentf8cde3a2f689eec00d0a5f617542cff435ed860c (diff)
downloadbackoffice-188b21026024cd79a2b6942f5d9d309fd7640371.tar.gz
backoffice-188b21026024cd79a2b6942f5d9d309fd7640371.tar.bz2
backoffice-188b21026024cd79a2b6942f5d9d309fd7640371.zip
Adapt JS tests to the latest logic.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 12 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 934db2a..2eee4c7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -39,9 +39,20 @@ AC_CHECK_PROG([tsc],[tsc],[yes],[no])
AM_CONDITIONAL([HAVE_TSC], [test "x$tsc" = xyes])
#
+# Check for Yarn
+#
+AC_MSG_CHECKING([Yarn])
+yarn --version &> /dev/null
+if test $? -ne 0;
+ then
+ AC_MSG_ERROR([Please install Yarn])
+fi
+
+
+#
# Check for minifier
#
-AC_MSG_CHECKING([Checking for jsmin])
+AC_MSG_CHECKING([jsmin])
python3 -m jsmin &> /dev/null
if test $? -ne 0;
then