summaryrefslogtreecommitdiff
path: root/contrib/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'contrib/Makefile.am')
-rw-r--r--contrib/Makefile.am58
1 files changed, 13 insertions, 45 deletions
diff --git a/contrib/Makefile.am b/contrib/Makefile.am
index b175a23..47c5e8e 100644
--- a/contrib/Makefile.am
+++ b/contrib/Makefile.am
@@ -3,25 +3,18 @@
SUBDIRS = .
-# English (en)
-tosendir=$(datadir)/anastasis/tos/en
+bin_SCRIPTS = \
+ anastasis-dbconfig
-# English (en)
-ppendir=$(datadir)/anastasis/pp/en
+termsdir=$(datadir)/anastasis/terms/
+terms_DATA = \
+ anastasis-tos-v0.rst \
+ anastasis-pp-v0.rst
-tosen_DATA = \
- tos/en/0.txt \
- tos/en/0.pdf \
- tos/en/0.epub \
- tos/en/0.xml \
- tos/en/0.html
-
-ppen_DATA = \
- pp/en/0.txt \
- pp/en/0.pdf \
- pp/en/0.epub \
- pp/en/0.xml \
- pp/en/0.html
+install-exec-local:
+ find locale/ -name "*.po"
+ mkdir -p $(DESTDIR)$(datadir)
+ cp --parents -r $$(find locale/ -name "*.po") $(DESTDIR)$(datadir)
extracted.h: *.json
./extract.sh
@@ -31,19 +24,10 @@ noinst_SCRIPTS = extracted.h
pkgdatadir= $(prefix)/share/anastasis/
EXTRA_DIST = \
+ locale/de/LC_MESSAGES/anastasis-tos-v0.po \
+ $(bin_SCRIPTS) \
$(pkgdata_DATA) \
- $(tosen_DATA) \
- $(ppen_DATA) \
- tos/Makefile \
- tos/README \
- tos/tos.rst \
- tos/conf.py \
- tos/locale/de/LC_MESSAGES/tos.po \
- pp/Makefile \
- pp/README \
- pp/pp.rst \
- pp/conf.py \
- pp/locale/de/LC_MESSAGES/pp.po \
+ $(terms_DATA) \
pogen.sh \
uncrustify.cfg \
uncrustify_precommit \
@@ -71,19 +55,3 @@ pkgdata_DATA = \
redux.xx.json \
redux.countries.json \
provider-list.json
-
-# Change the set of supported languages here. You should
-# also update tos'XX'data and EXTRA_DIST accordingly.
-TOS_LANGUAGES="en de"
-PP_LANGUAGES="en de"
-
-# Change the terms-of-service version (Etag) to generate here!
-# This value should be incremented whenever there is a substantive
-# change in the original text (but not for the translations).
-TOS_VERSION=0
-PP_VERSION=0
-
-update-tos:
- VERSION=$(TOS_VERSION) ./update-tos.sh $(TOS_LANGUAGES)
-update-pp:
- VERSION=$(PP_VERSION) ./update-pp.sh $(PP_LANGUAGES)