summaryrefslogtreecommitdiff
path: root/src/authorization/Makefile.am
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2021-09-26 19:24:14 +0200
committerChristian Grothoff <christian@grothoff.org>2021-09-26 19:24:14 +0200
commitf2dbb45c194cfc41395b7a13a828e24ceeb7bc89 (patch)
treedfb104db289c3c3f306bbf0ec3a956631e412a04 /src/authorization/Makefile.am
parentf70f4ce7e052569d171af503034811fc0dfe9d19 (diff)
downloadanastasis-f2dbb45c194cfc41395b7a13a828e24ceeb7bc89.tar.gz
anastasis-f2dbb45c194cfc41395b7a13a828e24ceeb7bc89.tar.bz2
anastasis-f2dbb45c194cfc41395b7a13a828e24ceeb7bc89.zip
starting with TOTP plugin for #7023
Diffstat (limited to 'src/authorization/Makefile.am')
-rw-r--r--src/authorization/Makefile.am21
1 files changed, 20 insertions, 1 deletions
diff --git a/src/authorization/Makefile.am b/src/authorization/Makefile.am
index cfcd89e..c99c6b4 100644
--- a/src/authorization/Makefile.am
+++ b/src/authorization/Makefile.am
@@ -69,7 +69,8 @@ plugin_LTLIBRARIES = \
libanastasis_plugin_authorization_file.la \
libanastasis_plugin_authorization_iban.la \
libanastasis_plugin_authorization_post.la \
- libanastasis_plugin_authorization_sms.la
+ libanastasis_plugin_authorization_sms.la \
+ libanastasis_plugin_authorization_totp.la
libanastasis_plugin_authorization_file_la_SOURCES = \
@@ -151,3 +152,21 @@ libanastasis_plugin_authorization_sms_la_LDFLAGS = \
-ljansson \
-lmicrohttpd \
$(XLIB)
+
+
+libanastasis_plugin_authorization_totp_la_SOURCES = \
+ anastasis_authorization_plugin_totp.c
+libanastasis_plugin_authorization_totp_la_LIBADD = \
+ $(LTLIBINTL)
+libanastasis_plugin_authorization_totp_la_LDFLAGS = \
+ $(ANASTASIS_PLUGIN_LDFLAGS) \
+ $(top_builddir)/src/stasis/libanastasisdb.la \
+ -ltalerjson \
+ -ltalermhd \
+ -ltalerutil \
+ -lgnunetjson \
+ -lgnunetutil \
+ -ljansson \
+ -lmicrohttpd \
+ -lgcrypt \
+ $(XLIB)