summaryrefslogtreecommitdiff
path: root/contrib/Makefile.am
diff options
context:
space:
mode:
authorChristian Grothoff <grothoff@gnunet.org>2023-08-12 11:17:40 +0200
committerChristian Grothoff <grothoff@gnunet.org>2023-08-12 11:17:40 +0200
commit2071e9605e3b3b3255ef549783301e9425472d1f (patch)
treee091298d381750a767f29b1062743431436f7a7d /contrib/Makefile.am
parent8c5b9c306d3a845decaeeb49ce13dd5417375064 (diff)
downloadanastasis-2071e9605e3b3b3255ef549783301e9425472d1f.tar.gz
anastasis-2071e9605e3b3b3255ef549783301e9425472d1f.tar.bz2
anastasis-2071e9605e3b3b3255ef549783301e9425472d1f.zip
update TOS logic
Diffstat (limited to 'contrib/Makefile.am')
-rw-r--r--contrib/Makefile.am56
1 files changed, 11 insertions, 45 deletions
diff --git a/contrib/Makefile.am b/contrib/Makefile.am
index c51edfa..7a5e408 100644
--- a/contrib/Makefile.am
+++ b/contrib/Makefile.am
@@ -6,25 +6,16 @@ SUBDIRS = .
bin_SCRIPTS = \
anastasis-dbconfig
-# English (en)
-tosendir=$(datadir)/anastasis/tos/en
+termsdir=$(datadir)/anastasis/terms/
+terms_DATA = \
+ anastasis-tos-v0.rst \
+ anastasis-pp-v0.rst
-# English (en)
-ppendir=$(datadir)/anastasis/pp/en
-
-tosen_DATA = \
- tos/en/0.txt \
- tos/en/0.pdf \
- tos/en/0.epub \
- tos/en/0.xml \
- tos/en/0.html
-
-ppen_DATA = \
- pp/en/0.txt \
- pp/en/0.pdf \
- pp/en/0.epub \
- pp/en/0.xml \
- pp/en/0.html
+install-exec-local:
+ pwd
+ find locale/ -name "*.po"
+ mkdir -p $(termsdir)
+ cp --parents -r $$(find locale/ -name "*.po") $(termsdir)
extracted.h: *.json
./extract.sh
@@ -34,19 +25,9 @@ noinst_SCRIPTS = extracted.h
pkgdatadir= $(prefix)/share/anastasis/
EXTRA_DIST = \
+ locale/de/LC_MESSAGES/anastasis-tos-v0.po \
$(pkgdata_DATA) \
- $(tosen_DATA) \
- $(ppen_DATA) \
- tos/Makefile \
- tos/README \
- tos/tos.rst \
- tos/conf.py \
- tos/locale/de/LC_MESSAGES/tos.po \
- pp/Makefile \
- pp/README \
- pp/pp.rst \
- pp/conf.py \
- pp/locale/de/LC_MESSAGES/pp.po \
+ $(terms_DATA) \
pogen.sh \
uncrustify.cfg \
uncrustify_precommit \
@@ -75,18 +56,3 @@ pkgdata_DATA = \
redux.countries.json \
provider-list.json
-# Change the set of supported languages here. You should
-# also update tos'XX'data and EXTRA_DIST accordingly.
-TOS_LANGUAGES="en de"
-PP_LANGUAGES="en de"
-
-# Change the terms-of-service version (Etag) to generate here!
-# This value should be incremented whenever there is a substantive
-# change in the original text (but not for the translations).
-TOS_VERSION=0
-PP_VERSION=0
-
-update-tos:
- VERSION=$(TOS_VERSION) ./update-tos.sh $(TOS_LANGUAGES)
-update-pp:
- VERSION=$(PP_VERSION) ./update-pp.sh $(PP_LANGUAGES)