diff options
Diffstat (limited to 'configure.ac')
-rw-r--r-- | configure.ac | 16 |
1 files changed, 6 insertions, 10 deletions
diff --git a/configure.ac b/configure.ac index 08b8e94..ba8f7c5 100644 --- a/configure.ac +++ b/configure.ac | |||
@@ -19,7 +19,7 @@ | |||
19 | # | 19 | # |
20 | # Process this file with autoconf to produce a configure script. | 20 | # Process this file with autoconf to produce a configure script. |
21 | # | 21 | # |
22 | AC_PREREQ(2.61) | 22 | AC_PREREQ([2.69]) |
23 | AC_INIT([Anastasis GTK],[0.2.0],[bug-anastasis@gnu.org],[anastasis-gtk]) | 23 | AC_INIT([Anastasis GTK],[0.2.0],[bug-anastasis@gnu.org],[anastasis-gtk]) |
24 | AC_CONFIG_AUX_DIR([build-aux]) | 24 | AC_CONFIG_AUX_DIR([build-aux]) |
25 | AM_INIT_AUTOMAKE([silent-rules]) | 25 | AM_INIT_AUTOMAKE([silent-rules]) |
@@ -27,22 +27,19 @@ AC_CONFIG_HEADERS([anastasis_gtk_config.h]) | |||
27 | 27 | ||
28 | AH_TOP([#define _GNU_SOURCE 1]) | 28 | AH_TOP([#define _GNU_SOURCE 1]) |
29 | 29 | ||
30 | AC_ISC_POSIX | ||
31 | AC_PROG_AWK | 30 | AC_PROG_AWK |
32 | AM_PROG_CC_C_O | 31 | AM_PROG_CC_C_O |
33 | AC_PROG_MKDIR_P | 32 | AC_PROG_MKDIR_P |
34 | AC_PROG_CPP | 33 | AC_PROG_CPP |
35 | AC_PROG_CC_C99 | 34 | AC_PROG_CC |
36 | AC_PROG_INSTALL | 35 | AC_PROG_INSTALL |
37 | AC_PROG_LN_S | 36 | AC_PROG_LN_S |
38 | AC_PROG_MAKE_SET | 37 | AC_PROG_MAKE_SET |
39 | AC_LIBTOOL_WIN32_DLL | ||
40 | AC_HEADER_STDC | ||
41 | AC_CANONICAL_HOST | 38 | AC_CANONICAL_HOST |
42 | 39 | ||
43 | # dynamic libraries/plugins | 40 | # dynamic libraries/plugins |
44 | AC_DISABLE_STATIC | 41 | AC_DISABLE_STATIC |
45 | AC_PROG_LIBTOOL | 42 | LT_INIT |
46 | 43 | ||
47 | AC_SYS_LARGEFILE | 44 | AC_SYS_LARGEFILE |
48 | AC_FUNC_FSEEKO | 45 | AC_FUNC_FSEEKO |
@@ -350,9 +347,7 @@ AS_IF([test $microhttpd = 0], | |||
350 | 347 | ||
351 | AC_MSG_CHECKING(for gtk) | 348 | AC_MSG_CHECKING(for gtk) |
352 | without_gtk=true | 349 | without_gtk=true |
353 | PKG_CHECK_MODULES([GTK], [gtk+-3.0]) | 350 | PKG_CHECK_MODULES([GTK], [gtk+-3.22]) |
354 | |||
355 | AM_PATH_GTK_3_0([3.22.0],,AC_MSG_ERROR([anastasis-gtk requires GTK 3.22])) | ||
356 | 351 | ||
357 | CFLAGS="$CFLAGS $GTK_CFLAGS" | 352 | CFLAGS="$CFLAGS $GTK_CFLAGS" |
358 | CPPFLAGS="$CPPFLAGS $GTK_CFLAGS" | 353 | CPPFLAGS="$CPPFLAGS $GTK_CFLAGS" |
@@ -492,7 +487,7 @@ AS_IF([test -n "$SOURCE_DATE_EPOCH"], | |||
492 | [thisyear=$(date +%Y)]) | 487 | [thisyear=$(date +%Y)]) |
493 | AC_SUBST(ANASTASIS_GTK_YEARTO, ${thisyear}, [year of the most current release]) | 488 | AC_SUBST(ANASTASIS_GTK_YEARTO, ${thisyear}, [year of the most current release]) |
494 | 489 | ||
495 | AC_OUTPUT([ | 490 | AC_CONFIG_FILES([ |
496 | Makefile | 491 | Makefile |
497 | contrib/Makefile | 492 | contrib/Makefile |
498 | doc/Makefile | 493 | doc/Makefile |
@@ -505,3 +500,4 @@ po/Makefile.in | |||
505 | po/Makefile | 500 | po/Makefile |
506 | anastasis-gtk.desktop | 501 | anastasis-gtk.desktop |
507 | ]) | 502 | ]) |
503 | AC_OUTPUT | ||