aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 6 insertions, 10 deletions
diff --git a/configure.ac b/configure.ac
index 08b8e94..ba8f7c5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -19,7 +19,7 @@
19# 19#
20# Process this file with autoconf to produce a configure script. 20# Process this file with autoconf to produce a configure script.
21# 21#
22AC_PREREQ(2.61) 22AC_PREREQ([2.69])
23AC_INIT([Anastasis GTK],[0.2.0],[bug-anastasis@gnu.org],[anastasis-gtk]) 23AC_INIT([Anastasis GTK],[0.2.0],[bug-anastasis@gnu.org],[anastasis-gtk])
24AC_CONFIG_AUX_DIR([build-aux]) 24AC_CONFIG_AUX_DIR([build-aux])
25AM_INIT_AUTOMAKE([silent-rules]) 25AM_INIT_AUTOMAKE([silent-rules])
@@ -27,22 +27,19 @@ AC_CONFIG_HEADERS([anastasis_gtk_config.h])
27 27
28AH_TOP([#define _GNU_SOURCE 1]) 28AH_TOP([#define _GNU_SOURCE 1])
29 29
30AC_ISC_POSIX
31AC_PROG_AWK 30AC_PROG_AWK
32AM_PROG_CC_C_O 31AM_PROG_CC_C_O
33AC_PROG_MKDIR_P 32AC_PROG_MKDIR_P
34AC_PROG_CPP 33AC_PROG_CPP
35AC_PROG_CC_C99 34AC_PROG_CC
36AC_PROG_INSTALL 35AC_PROG_INSTALL
37AC_PROG_LN_S 36AC_PROG_LN_S
38AC_PROG_MAKE_SET 37AC_PROG_MAKE_SET
39AC_LIBTOOL_WIN32_DLL
40AC_HEADER_STDC
41AC_CANONICAL_HOST 38AC_CANONICAL_HOST
42 39
43# dynamic libraries/plugins 40# dynamic libraries/plugins
44AC_DISABLE_STATIC 41AC_DISABLE_STATIC
45AC_PROG_LIBTOOL 42LT_INIT
46 43
47AC_SYS_LARGEFILE 44AC_SYS_LARGEFILE
48AC_FUNC_FSEEKO 45AC_FUNC_FSEEKO
@@ -350,9 +347,7 @@ AS_IF([test $microhttpd = 0],
350 347
351AC_MSG_CHECKING(for gtk) 348AC_MSG_CHECKING(for gtk)
352without_gtk=true 349without_gtk=true
353PKG_CHECK_MODULES([GTK], [gtk+-3.0]) 350PKG_CHECK_MODULES([GTK], [gtk+-3.22])
354
355AM_PATH_GTK_3_0([3.22.0],,AC_MSG_ERROR([anastasis-gtk requires GTK 3.22]))
356 351
357CFLAGS="$CFLAGS $GTK_CFLAGS" 352CFLAGS="$CFLAGS $GTK_CFLAGS"
358CPPFLAGS="$CPPFLAGS $GTK_CFLAGS" 353CPPFLAGS="$CPPFLAGS $GTK_CFLAGS"
@@ -492,7 +487,7 @@ AS_IF([test -n "$SOURCE_DATE_EPOCH"],
492 [thisyear=$(date +%Y)]) 487 [thisyear=$(date +%Y)])
493AC_SUBST(ANASTASIS_GTK_YEARTO, ${thisyear}, [year of the most current release]) 488AC_SUBST(ANASTASIS_GTK_YEARTO, ${thisyear}, [year of the most current release])
494 489
495AC_OUTPUT([ 490AC_CONFIG_FILES([
496Makefile 491Makefile
497contrib/Makefile 492contrib/Makefile
498doc/Makefile 493doc/Makefile
@@ -505,3 +500,4 @@ po/Makefile.in
505po/Makefile 500po/Makefile
506anastasis-gtk.desktop 501anastasis-gtk.desktop
507]) 502])
503AC_OUTPUT