summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac28
1 files changed, 27 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index afdb266..7820aec 100644
--- a/configure.ac
+++ b/configure.ac
@@ -88,7 +88,6 @@ AS_IF([test $libgnunetutil != 1],
*** https://gnunet.org
*** ]])])
-
# Check for GNUnet's libgnunetjson.
libgnunetjson=0
AC_MSG_CHECKING([for libgnunetjson])
@@ -265,6 +264,33 @@ CFLAGS=$CFLAGS_SAVE
LDFLAGS=$LDFLAGS_SAVE
LIBS=$LIBS_SAVE
+# Check for Taler's libtalertesting
+libtalertesting=0
+AC_MSG_CHECKING([for libtalertesting])
+AC_ARG_WITH(exchange,
+ [AS_HELP_STRING([--with-exchange=PFX],
+ [base of Taler EXCHANGE installation, provides testing dependency.])],
+ [AC_MSG_RESULT([given as $with_exchange])],
+ [AC_MSG_RESULT(not given)
+ with_exchange=yes])
+AS_CASE([$with_exchange],
+ [yes], [],
+ [no], [],
+ [LDFLAGS="-L$with_exchange/lib $LDFLAGS"
+ CPPFLAGS="-I$with_exchange/include $CPPFLAGS"])
+
+CPPFLAGS="$CPPFLAGS"
+LDFLAGS="$LDFLAGS -L/usr/local/lib"
+
+
+
+AC_CHECK_HEADERS([gnunet/platform.h taler/taler_testing_lib.h],
+ [AC_CHECK_LIB([talertesting], [TALER_TESTING_setup], libtalertesting=1,,[-ltalerexchange -ltalerbank])],
+ [], [#ifdef HAVE_GNUNET_PLATFORM_H
+ #include <gnunet/platform.h>
+ #endif])
+
+AM_CONDITIONAL(HAVE_TALERTESTING, test x$libtalertesting = x1)
# should developer logic be compiled (not-for-production code)?
AC_MSG_CHECKING(whether to compile developer logic)