summaryrefslogtreecommitdiff
path: root/src/lib/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/lib/Makefile.am')
-rw-r--r--src/lib/Makefile.am24
1 files changed, 24 insertions, 0 deletions
diff --git a/src/lib/Makefile.am b/src/lib/Makefile.am
index 1462eb5..fa160a6 100644
--- a/src/lib/Makefile.am
+++ b/src/lib/Makefile.am
@@ -45,6 +45,30 @@ libsynctesting_la_LIBADD = \
-ltalertesting \
$(XLIB)
+check_PROGRAMS = \
+ test_sync_api
+
+TESTS = \
+ $(check_PROGRAMS)
+
+test_sync_api_SOURCES = \
+ test_sync_api.c
+test_sync_api_LDADD = \
+ libsync.la \
+ libsynctesting.la \
+ -ltalertesting \
+ -ltalermerchanttesting \
+ -ltalerfakebank \
+ -ltalerbank \
+ -ltalerexchange \
+ -ltalermerchant \
+ -ltalerjson \
+ -ltalerutil \
+ -lgnunetjson \
+ -lgnunetcurl \
+ -lgnunetutil \
+ -ljansson
+
if HAVE_LIBCURL
libsync_la_LIBADD += -lcurl
else