aboutsummaryrefslogtreecommitdiff
path: root/src/lib/Makefile.am
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2019-11-13 15:01:09 +0100
committerChristian Grothoff <christian@grothoff.org>2019-11-13 15:01:09 +0100
commitc8047726772c2f4a18a6b0ebc7ce879bf260860a (patch)
treea6bab2e9a42c72a720c893b9c2505077067e6bfc /src/lib/Makefile.am
downloadsync-c8047726772c2f4a18a6b0ebc7ce879bf260860a.tar.gz
sync-c8047726772c2f4a18a6b0ebc7ce879bf260860a.tar.bz2
sync-c8047726772c2f4a18a6b0ebc7ce879bf260860a.zip
skeleton
Diffstat (limited to 'src/lib/Makefile.am')
-rw-r--r--src/lib/Makefile.am32
1 files changed, 32 insertions, 0 deletions
diff --git a/src/lib/Makefile.am b/src/lib/Makefile.am
new file mode 100644
index 0000000..5f05c26
--- /dev/null
+++ b/src/lib/Makefile.am
@@ -0,0 +1,32 @@
+# This Makefile.am is in the public domain
+AM_CPPFLAGS = -I$(top_srcdir)/src/include
+
+if USE_COVERAGE
+ AM_CFLAGS = --coverage -O0
+ XLIB = -lgcov
+endif
+
+lib_LTLIBRARIES = \
+ libsync.la
+
+libsync_la_LDFLAGS = \
+ -version-info 0:0:0 \
+ -no-undefined
+
+libsync_la_SOURCES = \
+ sync_api_upload.c
+
+libsync_la_LIBADD = \
+ -lgnunetcurl \
+ -lgnunetjson \
+ -lgnunetutil \
+ -ljansson \
+ $(XLIB)
+
+if HAVE_LIBCURL
+libsync_la_LIBADD += -lcurl
+else
+if HAVE_LIBGNURL
+libsync_la_LIBADD += -lgnurl
+endif
+endif