summaryrefslogtreecommitdiff
path: root/fflate/rs/fflate/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'fflate/rs/fflate/Cargo.toml')
-rw-r--r--fflate/rs/fflate/Cargo.toml37
1 files changed, 37 insertions, 0 deletions
diff --git a/fflate/rs/fflate/Cargo.toml b/fflate/rs/fflate/Cargo.toml
new file mode 100644
index 0000000..afc9639
--- /dev/null
+++ b/fflate/rs/fflate/Cargo.toml
@@ -0,0 +1,37 @@
+[package]
+name = "fflate"
+version = "0.0.1"
+authors = ["Arjun Barrett <arjunbarrett@gmail.com>"]
+description = "A fast, efficient, pure Rust compression library"
+repository = "https://github.com/101arrowz/fflate"
+license = "MIT"
+keywords = [
+ "compression",
+ "decompression",
+ "deflate",
+ "inflate",
+ "gzip",
+ "gunzip",
+ "zlib",
+ "zip",
+ "libflate",
+ "flate2"
+]
+edition = "2018"
+
+[dependencies]
+lazy_static = "1.4"
+# TO REMOVE
+miniz_oxide = "*"
+
+[profile.release]
+opt-level = 3
+lto = true
+# TO FIX
+# debug = true
+
+[features]
+std = []
+
+[lib]
+crate-type = ["cdylib", "rlib"] \ No newline at end of file