summaryrefslogtreecommitdiff
path: root/src/mustach/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/mustach/Makefile.am')
-rw-r--r--src/mustach/Makefile.am12
1 files changed, 11 insertions, 1 deletions
diff --git a/src/mustach/Makefile.am b/src/mustach/Makefile.am
index a39a28d0..ac9f2842 100644
--- a/src/mustach/Makefile.am
+++ b/src/mustach/Makefile.am
@@ -11,7 +11,17 @@ lib_LIBRARIES = \
libmustach.a
libmustach_a_SOURCES = \
- mustach.c mustach.h
+ mustach.c mustach.h \
+ mustach-jansson.c mustach-jansson.h
+
+test_mustach_jansson_SOURCES = \
+ test_mustach_jansson.c
+test_mustach_jansson_LDADD = \
+ -lgnunetutil \
+ libmustach.a
+
+check_PROGRAMS = \
+ test_mustach_jansson
check_SCRIPTS = \
run-original-tests.sh