summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2022-12-08 14:20:43 +0100
committerChristian Grothoff <christian@grothoff.org>2022-12-08 14:20:43 +0100
commita81278253f05d99d95b1b7732991e80476cfbd90 (patch)
tree7457c4180a943e4533a1f9fb055ccbd140c1dd4b /configure.ac
parentf160682f5a315cb3fb177477218978aef7b4f5e9 (diff)
downloadmerchant-a81278253f05d99d95b1b7732991e80476cfbd90.tar.gz
merchant-a81278253f05d99d95b1b7732991e80476cfbd90.tar.bz2
merchant-a81278253f05d99d95b1b7732991e80476cfbd90.zip
-improve postgres check
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac17
1 files changed, 13 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 9b2c1deb..5293f3f4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -91,10 +91,19 @@ AS_IF([test $libgnunetutil != 1],
# test for postgres
-AX_LIB_POSTGRESQL([9.3])
-AS_IF([test "x$found_postgresql" = "xyes"],[postgres=true])
-AM_CONDITIONAL(HAVE_POSTGRESQL, test x$postgres = xtrue)
-
+AX_LIB_POSTGRESQL([13.0])
+AS_IF([test "x$found_postgresql" = "xyes"],
+ [SAVE_CPPFLAGS="$CPPFLAGS"
+ CPPFLAGS="$POSTGRES_CPPFLAGS $CPPFLAGS"
+ AC_CHECK_HEADERS([libpq-fe.h], [postgres=1], [postgres=0])])
+AS_IF([test "x$postgres" != "x1"],
+ [AC_MSG_ERROR([[
+***
+*** You need libpq(-dev) >= 13.0 to build this program.
+*** ]])])
+AM_CONDITIONAL([HAVE_POSTGRESQL], [test "x$postgres" = "x1"])
+AC_DEFINE_UNQUOTED([HAVE_POSTGRESQL], [$postgres],
+ [Define to 1 if Postgres is available])
TALER_LIB_LDFLAGS="-export-dynamic -no-undefined"
TALER_PLUGIN_LDFLAGS="-export-dynamic -avoid-version -module -no-undefined"