summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMarcello Stanisci <stanisci.m@gmail.com>2018-06-28 13:23:34 +0200
committerMarcello Stanisci <stanisci.m@gmail.com>2018-06-28 13:23:34 +0200
commitec0c992568f518249aa21c04a650e1785b90994e (patch)
tree290cacb38ca7f78808d68d19cc01fbe5e7f11da8 /configure.ac
parentcbd2ca3f1e75b84758bc5bd4275e49702e2844c1 (diff)
downloadmerchant-ec0c992568f518249aa21c04a650e1785b90994e.tar.gz
merchant-ec0c992568f518249aa21c04a650e1785b90994e.tar.bz2
merchant-ec0c992568f518249aa21c04a650e1785b90994e.zip
Conditional compilation of twisted-chunk.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 5 insertions, 11 deletions
diff --git a/configure.ac b/configure.ac
index 3d57949f..6e297106 100644
--- a/configure.ac
+++ b/configure.ac
@@ -233,17 +233,11 @@ AS_CASE([$with_twister],
[LDFLAGS="-L$with_twister/lib $LDFLAGS"
CPPFLAGS="-I$with_twister/include $CPPFLAGS"])
-# This tries to include the twister even though
-# no --with-twister option was given. Shall it
-# be included only if the user explicitly gave
-# such option?
-AC_CHECK_LIB(talertwistertesting,TALER_TESTING_run_twister,
- [AC_CHECK_HEADER([taler/taler_twister_testing_lib.h],[twistertesting=1],,
- [#ifdef HAVE_GNUNET_PLATFORM_H
- #include <gnunet/platform.h>
- #endif
- ])]
- ,,[-ltalerexchange -ltalerbank])
+AC_CHECK_HEADERS([taler/taler_twister_testing_lib.h],
+ [AC_CHECK_LIB([talertwistertesting], [TALER_TESTING_run_twister], twistertesting=1)],
+ [], [#ifdef HAVE_GNUNET_PLATFORM_H
+ #include <gnunet/platform.h>
+ #endif])
AM_CONDITIONAL(HAVE_TWISTER, test x$twistertesting = x1)
# gcov compilation