summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2021-01-01 21:54:02 +0100
committerChristian Grothoff <christian@grothoff.org>2021-01-01 21:54:02 +0100
commita0a8f482fb69d6fc79e13f3fba302fc7ff964a3f (patch)
tree5d5a9b132277db3eb85af8777410dfeeb09d6813 /configure.ac
parentd2b1596bbd6a56cdc57a65764e051179108313d5 (diff)
downloadmerchant-a0a8f482fb69d6fc79e13f3fba302fc7ff964a3f.tar.gz
merchant-a0a8f482fb69d6fc79e13f3fba302fc7ff964a3f.tar.bz2
merchant-a0a8f482fb69d6fc79e13f3fba302fc7ff964a3f.zip
fix linker issues
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 8 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 837c33cc..99801c6c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -85,6 +85,14 @@ AX_LIB_POSTGRESQL([9.3])
AS_IF([test "x$found_postgresql" = "xyes"],[postgres=true])
AM_CONDITIONAL(HAVE_POSTGRESQL, test x$postgres = xtrue)
+
+TALER_LIB_LDFLAGS="-export-dynamic -no-undefined"
+TALER_PLUGIN_LDFLAGS="-export-dynamic -avoid-version -module -no-undefined"
+
+AC_SUBST(TALER_LIB_LDFLAGS)
+AC_SUBST(TALER_PLUGIN_LDFLAGS)
+
+
# Check for Taler's libtalerpq
libtalerpq=0
AC_MSG_CHECKING([for libtalerpq])