summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMarcello Stanisci <stanisci.m@gmail.com>2018-03-06 11:51:44 +0100
committerMarcello Stanisci <stanisci.m@gmail.com>2018-03-17 01:37:10 +0100
commitc1b34d21be91cf91a17f04c7f8e490e9b49e5e66 (patch)
tree852086b02264767d2592b63a94c6fe286aae83d7 /configure.ac
parentc8e6304463e1771200c1fb336d9b4aeea7cb7d81 (diff)
downloadmerchant-c1b34d21be91cf91a17f04c7f8e490e9b49e5e66.tar.gz
merchant-c1b34d21be91cf91a17f04c7f8e490e9b49e5e66.tar.bz2
merchant-c1b34d21be91cf91a17f04c7f8e490e9b49e5e66.zip
check if twister is installed.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac21
1 files changed, 21 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index b13a58a5..33854615 100644
--- a/configure.ac
+++ b/configure.ac
@@ -218,6 +218,27 @@ then
fi
fi
+# check for libtalertwistertesting
+twistertesting=0
+AC_MSG_CHECKING([for talerwtistertesting])
+AC_ARG_WITH([twister],
+ [AS_HELP_STRING([--with-twister=PFX], [base of libtalertwistertesting])],
+ [AC_MSG_RESULT([given as $with_twister])],
+ [AC_MSG_RESULT([not given])
+ with_twister=yes])
+AS_CASE([$with_twister],
+ [yes], [],
+ [no], [AC_MSG_WARN([no twister-testing will be compiled])],
+ [LDFLAGS="-L$with_twister/lib $LDFLAGS"
+ CPPFLAGS="-I$with_twister/include $CPPFLAGS"])
+AC_CHECK_LIB(talertwistertesting,TALER_TESTING_run_twister,
+ [AC_CHECK_HEADER([taler/taler_twister_testing_lib.h],[twistertesting=1],,
+ [#ifdef HAVE_GNUNET_PLATFORM_H
+ #include <gnunet/platform.h>
+ #endif])]
+ ,,[-ltalerexchange -ltalerbank])
+AM_CONDITIONAL(HAVE_TWISTER, test x$twistertesting = x1)
+
# gcov compilation
AC_MSG_CHECKING(whether to compile with support for code coverage analysis)
AC_ARG_ENABLE([coverage],