summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2020-05-19 01:21:00 +0200
committerChristian Grothoff <christian@grothoff.org>2020-05-19 01:21:00 +0200
commit0767f8fbf946006031b5e680e5b190af05e4b373 (patch)
tree488aa2684633933e752b2a79156dcc5322f67f6f /configure.ac
parent211a3cb0db1ac6c97835100b4d128d338b19ba0a (diff)
parent9782a228c1db595fbd25ee0838109371d1787697 (diff)
downloadmerchant-0767f8fbf946006031b5e680e5b190af05e4b373.tar.gz
merchant-0767f8fbf946006031b5e680e5b190af05e4b373.tar.bz2
merchant-0767f8fbf946006031b5e680e5b190af05e4b373.zip
Merge branch 'master' into protocolV1
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 3 insertions, 7 deletions
diff --git a/configure.ac b/configure.ac
index d0a28bc7..aa14d8b3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -142,7 +142,7 @@ AS_IF([test "x$gnurl" = x1],[
AM_CONDITIONAL(HAVE_LIBGNURL, false)
])
-# libcurl-gnutls
+# libcurl
LIBCURL_CHECK_CONFIG(,7.34.0,[curl=true],[curl=false])
AS_IF([test "x$curl" = xtrue],
[LDFLAGS="-L$with_libcurl/lib $LDFLAGS"
@@ -152,11 +152,7 @@ AS_IF([test "x$curl" = xtrue],
[curl=true],
[curl=false],
[[#include <curl/curl.h>]])],
- [curl=false])
- # need libcurl-gnutls.so, everything else is not acceptable
- AC_CHECK_LIB([curl-gnutls],
- [curl_easy_getinfo],,
- [curl=false])])
+ [curl=false])])
# cURL must support CURLINFO_TLS_SESSION, version >= 7.34
# Check for curl/curl.h and gnurl/curl.h so we can use #ifdef
@@ -171,7 +167,7 @@ AC_CHECK_HEADERS([curl/curl.h],,
AS_IF([test "x$gnurl" = "x0"],
[AS_IF([test "x$curl" = "x0"],
[AC_MSG_NOTICE([NOTICE: libgnurl not found. taler-bank support will not be compiled.])],
- [AC_MSG_NOTICE([WARNING: libgnurl not found, trying to use libcurl-gnutls instead.])])])
+ [AC_MSG_NOTICE([WARNING: libgnurl not found, trying to use libcurl instead.])])])
AS_IF([test x$curl = xfalse],
[AM_CONDITIONAL(HAVE_LIBCURL, false)