summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2023-03-02 14:41:46 +0100
committerChristian Grothoff <christian@grothoff.org>2023-03-02 14:41:46 +0100
commitf9378fd23f581a48ea0d1754c5d5beb3cbc7bd1e (patch)
treee54c68905192329f8f7d137fd5e791ffcce88b86 /debian
parentb5c14d235d63aacf5fa00ddf05a36dde20860106 (diff)
parent09482f4c01d552728a2963e147cd89a29d47e639 (diff)
downloadlibeufin-f9378fd23f581a48ea0d1754c5d5beb3cbc7bd1e.tar.gz
libeufin-f9378fd23f581a48ea0d1754c5d5beb3cbc7bd1e.tar.bz2
libeufin-f9378fd23f581a48ea0d1754c5d5beb3cbc7bd1e.zip
update Debian package of libeufin to include more DB setup logic
Diffstat (limited to 'debian')
-rw-r--r--debian/control1
-rw-r--r--debian/etc/nginx/sites-available/libeufin-sandbox.conf37
-rw-r--r--debian/libeufin.install4
3 files changed, 42 insertions, 0 deletions
diff --git a/debian/control b/debian/control
index d15a4346..465c1b55 100644
--- a/debian/control
+++ b/debian/control
@@ -17,6 +17,7 @@ Depends: openjdk-11-jdk-headless | openjdk-11-jdk | openjdk-12-jdk-headless | op
python3 (>= 3.7),
python3-click,
python3-requests,
+ apache2 | nginx | httpd,
${misc:Depends}
Recommends:
Description: Software package to access FinTS/EBICS based
diff --git a/debian/etc/nginx/sites-available/libeufin-sandbox.conf b/debian/etc/nginx/sites-available/libeufin-sandbox.conf
new file mode 100644
index 00000000..23046e90
--- /dev/null
+++ b/debian/etc/nginx/sites-available/libeufin-sandbox.conf
@@ -0,0 +1,37 @@
+server {
+ include /etc/nginx/mime.types;
+
+ # NOTE:
+ # - urgently consider configuring TLS instead
+ # - maybe keep a forwarder from HTTP to HTTPS
+ listen 80;
+
+ # NOTE:
+ # - Comment out this line if you have no IPv6
+ listen [::]:80;
+
+ # NOTE:
+ # - replace with your actual server name.
+ server_name localhost;
+
+ # Doesn't take requests away from the backend,
+ # because that expects always a "/demobanks/default"
+ # prefix.
+ rewrite ^/$ /webui/index.html;
+
+ # FRONTEND
+ location /webui {
+ # This location has both the SPA HTML and the
+ # JavaScript configuration demobank-ui-settings.js
+ alias /usr/share/taler/demobank-ui;
+ }
+
+ # BACKEND
+ location / {
+ # NOTE: urgently change to 'https' once TLS has been configured.
+ proxy_set_header X-Forwarded-Proto "$scheme";
+ proxy_set_header X-Forwarded-Host "localhost";
+ proxy_set_header X-Forwarded-Prefix /;
+ proxy_pass http://localhost:5000/;
+ }
+}
diff --git a/debian/libeufin.install b/debian/libeufin.install
index 38a82ded..32213f72 100644
--- a/debian/libeufin.install
+++ b/debian/libeufin.install
@@ -2,3 +2,7 @@ debian/etc/* etc/
# Files needed by dbconf
debian/db/install/* usr/share/dbconfig-common/scripts/libeufin/install/
+
+# Install the SPA + JS config:
+debian/usr/share/libeufin/* usr/share/libeufin/
+