summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorMS <ms@taler.net>2023-01-19 14:17:45 +0100
committerMS <ms@taler.net>2023-01-19 14:17:45 +0100
commit7d925f01be038ea194ddd110c94e9d9321033bbd (patch)
tree6100c2e8abe2ea6ccf2861c8560ef4b9fa8e85fd /Makefile
parent008979f7b24f07e545532d2cb70b36aea0c2e234 (diff)
downloadlibeufin-7d925f01be038ea194ddd110c94e9d9321033bbd.tar.gz
libeufin-7d925f01be038ea194ddd110c94e9d9321033bbd.tar.bz2
libeufin-7d925f01be038ea194ddd110c94e9d9321033bbd.zip
Providing "make dist" based on Git.
Updating the README and adding another target to export executables: make exec-arch
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index 91576dbf..51ec2ca6 100644
--- a/Makefile
+++ b/Makefile
@@ -4,11 +4,17 @@ escaped_pwd = $(shell pwd | sed 's/\//\\\//g')
all: assemble
install: install-nexus install-sandbox install-cli
+git-archive-all = ./build-system/taler-build-scripts/archive-with-submodules/git_archive_all.py
.PHONY: dist
dist:
- @./gradlew -q dist
+ @mkdir -p build/distributions
+ @$(git-archive-all) --include ./configure build/distributions/libeufin-$(shell ./gradlew -q libeufinVersion)-sources.tar.gz
+
+.PHONY: exec-arch
+exec-arch:
+ @./gradlew -q execArch
.PHONY: deb
deb: dist