summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am41
1 files changed, 25 insertions, 16 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 46a075249..d5020093f 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -91,10 +91,19 @@ EXTRA_DIST = mkhelp.pl makefile.dj \
# Use absolute directory to disable VPATH
MANPAGE=$(abs_top_builddir)/docs/gnurl.1
-README=$(top_srcdir)/docs/MANUAL
MKHELP=$(top_srcdir)/src/mkhelp.pl
HUGE=tool_hugehelp.c
+HUGECMD = $(HUGEIT_$(V))
+HUGEIT_0 = @echo " HUGE " $@;
+HUGEIT_1 =
+HUGEIT_ = $(HUGEIT_0)
+
+CHECKSRC = $(CS_$(V))
+CS_0 = @echo " RUN " $@;
+CS_1 =
+CS_ = $(CS_0)
+
if USE_MANUAL
# Here are the stuff to create a built-in manual
@@ -104,33 +113,33 @@ $(MANPAGE):
if HAVE_LIBZ
# This generates the tool_hugehelp.c file in both uncompressed and
# compressed formats.
-$(HUGE): $(MANPAGE) $(README) $(MKHELP)
- echo '#include "tool_setup.h"' > $(HUGE)
- echo '#ifndef HAVE_LIBZ' >> $(HUGE)
- $(NROFF) $(MANPAGE) | $(PERL) $(MKHELP) $(README) >> $(HUGE)
- echo '#else' >> $(HUGE)
- $(NROFF) $(MANPAGE) | $(PERL) $(MKHELP) -c $(README) >> $(HUGE)
- echo '#endif /* HAVE_LIBZ */' >> $(HUGE)
+$(HUGE): $(MANPAGE) $(MKHELP)
+ $(HUGECMD) (echo '#include "tool_setup.h"' > $(HUGE); \
+ echo '#ifndef HAVE_LIBZ' >> $(HUGE); \
+ $(NROFF) $(MANPAGE) | $(PERL) $(MKHELP) >> $(HUGE); \
+ echo '#else' >> $(HUGE); \
+ $(NROFF) $(MANPAGE) | $(PERL) $(MKHELP) -c >> $(HUGE); \
+ echo '#endif /* HAVE_LIBZ */' >> $(HUGE) )
else # HAVE_LIBZ
# This generates the tool_hugehelp.c file uncompressed only
-$(HUGE): $(MANPAGE) $(README) $(MKHELP)
- echo '#include "tool_setup.h"' > $(HUGE)
- $(NROFF) $(MANPAGE) | $(PERL) $(MKHELP) $(README) >> $(HUGE)
+$(HUGE): $(MANPAGE) $(MKHELP)
+ $(HUGECMD)(echo '#include "tool_setup.h"' > $(HUGE): \
+ $(NROFF) $(MANPAGE) | $(PERL) $(MKHELP) >> $(HUGE) )
endif
else # USE_MANUAL
# built-in manual has been disabled, make a blank file
$(HUGE):
- echo "/* built-in manual is disabled, blank function */" > $(HUGE)
- echo '#include "tool_hugehelp.h"' >> $(HUGE)
- echo "void hugehelp(void) {}" >>$(HUGE)
+ $(HUGECMD)(echo "/* built-in manual is disabled, blank function */" > $(HUGE); \
+ echo '#include "tool_hugehelp.h"' >> $(HUGE); \
+ echo "void hugehelp(void) {}" >>$(HUGE) )
endif
# ignore tool_hugehelp.c since it is generated source code and it plays
# by slightly different rules!
checksrc:
- @PERL@ $(top_srcdir)/lib/checksrc.pl -D$(srcdir) \
- -W$(srcdir)/tool_hugehelp.c $(srcdir)/*.[ch]
+ $(CHECKSRC)(@PERL@ $(top_srcdir)/lib/checksrc.pl -D$(srcdir) \
+ -W$(srcdir)/tool_hugehelp.c $(srcdir)/*.[ch])
if CURLDEBUG
# for debug builds, we scan the sources on all regular make invokes