summaryrefslogtreecommitdiff
path: root/scripts/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'scripts/Makefile.am')
-rw-r--r--scripts/Makefile.am8
1 files changed, 4 insertions, 4 deletions
diff --git a/scripts/Makefile.am b/scripts/Makefile.am
index 297b8d29b..ec4747705 100644
--- a/scripts/Makefile.am
+++ b/scripts/Makefile.am
@@ -23,8 +23,8 @@ ZSH_FUNCTIONS_DIR = @ZSH_FUNCTIONS_DIR@
FISH_FUNCTIONS_DIR = @FISH_FUNCTIONS_DIR@
PERL = @PERL@
-ZSH_COMPLETION_FUNCTION_FILENAME = _curl
-FISH_COMPLETION_FUNCTION_FILENAME = curl.fish
+ZSH_COMPLETION_FUNCTION_FILENAME = _gnurl
+FISH_COMPLETION_FUNCTION_FILENAME = gnurl.fish
CLEANFILES = $(ZSH_COMPLETION_FUNCTION_FILENAME) $(FISH_COMPLETION_FUNCTION_FILENAME)
@@ -35,7 +35,7 @@ if CROSSCOMPILING
@echo "NOTICE: we can't generate zsh completion when cross-compiling!"
else # if not cross-compiling:
@if ! test -x "$(PERL)"; then echo "No perl: can't install completion.pl"; exit 0; fi
- $(PERL) $(srcdir)/completion.pl --curl $(top_builddir)/src/curl$(EXEEXT) --shell zsh > $@
+ $(PERL) $(srcdir)/completion.pl --curl $(top_builddir)/src/gnurl$(EXEEXT) --shell zsh > $@
endif
$(FISH_COMPLETION_FUNCTION_FILENAME): completion.pl
@@ -43,7 +43,7 @@ if CROSSCOMPILING
@echo "NOTICE: we can't generate fish completion when cross-compiling!"
else # if not cross-compiling:
@if ! test -x "$(PERL)"; then echo "No perl: can't install completion.pl"; exit 0; fi
- $(PERL) $(srcdir)/completion.pl --curl $(top_builddir)/src/curl$(EXEEXT) --shell fish > $@
+ $(PERL) $(srcdir)/completion.pl --curl $(top_builddir)/src/gnurl$(EXEEXT) --shell fish > $@
endif
install-data-local: