summaryrefslogtreecommitdiff
path: root/lib/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'lib/Makefile.am')
-rw-r--r--lib/Makefile.am26
1 files changed, 12 insertions, 14 deletions
diff --git a/lib/Makefile.am b/lib/Makefile.am
index 4501e5002..a6c361414 100644
--- a/lib/Makefile.am
+++ b/lib/Makefile.am
@@ -21,13 +21,15 @@
###########################################################################
AUTOMAKE_OPTIONS = foreign nostdinc
-EXTRA_DIST = Makefile.m32 config-win32.h config-win32ce.h \
- config-plan9.h config-riscos.h config-mac.h curl_config.h.in \
- makefile.dj config-dos.h libgnurl.plist libcurl.rc config-amigaos.h \
- makefile.amiga Makefile.netware nwlib.c nwos.c config-win32ce.h \
- config-os400.h setup-os400.h config-symbian.h Makefile.Watcom \
- config-tpf.h mk-ca-bundle.pl mk-ca-bundle.vbs \
- firefox-db2pem.sh config-vxworks.h Makefile.vxworks checksrc.pl
+ED_1 = Makefile.m32 config-win32.h config-win32ce.h
+ED_2 = config-plan9.h config-riscos.h config-mac.h curl_config.h.in
+ED_3 = makefile.dj config-dos.h libgnurl.plist libcurl.rc config-amigaos.h
+ED_4 = makefile.amiga Makefile.netware nwlib.c nwos.c config-win32ce.h
+ED_5 = config-os400.h setup-os400.h config-symbian.h Makefile.Watcom
+ED_6 = config-tpf.h mk-ca-bundle.pl mk-ca-bundle.vbs
+ED_7 = firefox-db2pem.sh config-vxworks.h Makefile.vxworks checksrc.pl
+
+EXTRA_DIST = $(ED_1) $(ED_2) $(ED_3) $(ED_4) $(ED_5) $(ED_6) $(ED_7)
lib_LTLIBRARIES = libgnurl.la
@@ -51,13 +53,10 @@ CFLAGS += @CURL_CFLAG_EXTRAS@
# $(top_builddir)/ares is for in-tree c-ares's generated ares_build.h file
# $(top_srcdir)/ares is for in-tree c-ares's external include files
-AM_CPPFLAGS = -I$(top_srcdir)/include \
- -I$(top_builddir)/lib \
- -I$(top_srcdir)/lib
+AM_CPPFLAGS = -I$(top_srcdir)/include -I$(top_builddir)/lib -I$(top_srcdir)/lib
if USE_EMBEDDED_ARES
-AM_CPPFLAGS += -I$(top_builddir)/ares \
- -I$(top_srcdir)/ares
+AM_CPPFLAGS += -I$(top_builddir)/ares -I$(top_srcdir)/ares
endif
# Prevent LIBS from being used for all link targets
@@ -135,8 +134,7 @@ CS_1 =
CS_ = $(CS_0)
checksrc:
- $(CHECKSRC)(@PERL@ $(srcdir)/checksrc.pl -D$(srcdir) -W$(srcdir)/curl_config.h \
- $(srcdir)/*.[ch] $(srcdir)/vauth/*.[ch] $(srcdir)/vtls/*.[ch] $(srcdir)/vquic/*.[ch] $(srcdir)/vssh/*.[ch])
+ $(CHECKSRC)(@PERL@ $(srcdir)/checksrc.pl -D$(srcdir) -W$(srcdir)/curl_config.h $(srcdir)/*.[ch] $(srcdir)/vauth/*.[ch] $(srcdir)/vtls/*.[ch] $(srcdir)/vquic/*.[ch] $(srcdir)/vssh/*.[ch])
if CURLDEBUG
# for debug builds, we scan the sources on all regular make invokes