summaryrefslogtreecommitdiff
path: root/docs/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'docs/Makefile.am')
-rw-r--r--docs/Makefile.am42
1 files changed, 10 insertions, 32 deletions
diff --git a/docs/Makefile.am b/docs/Makefile.am
index e34b80488..28e947742 100644
--- a/docs/Makefile.am
+++ b/docs/Makefile.am
@@ -24,21 +24,17 @@ AUTOMAKE_OPTIONS = foreign no-dependencies
# EXTRA_DIST breaks with $(abs_builddir) so build it using this variable
# but distribute it (using the relative file name) in the next variable
-man_MANS = $(abs_builddir)/curl.1
-noinst_man_MANS = curl.1 mk-ca-bundle.1
-dist_man_MANS = curl-config.1
-GENHTMLPAGES = curl.html curl-config.html mk-ca-bundle.html
-PDFPAGES = curl.pdf curl-config.pdf mk-ca-bundle.pdf
-MANDISTPAGES = curl.1.dist curl-config.1.dist
-
-HTMLPAGES = $(GENHTMLPAGES) index.html
+man_MANS = $(abs_builddir)/gnurl.1
+noinst_man_MANS = gnurl.1 mk-ca-bundle.1
+dist_man_MANS = gnurl-config.1
+MANDISTPAGES = gnurl.1.dist gnurl-config.1.dist
# Build targets in this file (.) before cmdline-opts to ensure that
# the curl.1 rule below runs first
-SUBDIRS = . cmdline-opts
+SUBDIRS = .
DIST_SUBDIRS = $(SUBDIRS) examples libcurl
-CLEANFILES = $(GENHTMLPAGES) $(PDFPAGES) $(MANDISTPAGES) curl.1
+CLEANFILES = $(MANDISTPAGES)
EXTRA_DIST = \
$(noinst_man_MANS) \
@@ -82,9 +78,7 @@ EXTRA_DIST = \
TheArtOfHttpScripting \
VERSIONS
-MAN2HTML= roffit $< >$@
-
-SUFFIXES = .1 .html .pdf
+SUFFIXES = .1
# $(abs_builddir) is to disable VPATH when searching for this file, which
# would otherwise find the copy in $(srcdir) which breaks the $(HUGE)
@@ -94,26 +88,10 @@ SUFFIXES = .1 .html .pdf
# First, seed the used copy of curl.1 with the prebuilt copy (in an out-of-tree
# build), then run make recursively to rebuild it only if its dependencies
# have changed.
-$(abs_builddir)/curl.1:
- if test "$(top_builddir)x" != "$(top_srcdir)x" -a -e "$(srcdir)/curl.1"; then \
- $(INSTALL_DATA) "$(srcdir)/curl.1" $@; fi
+$(abs_builddir)/gnurl.1:
+ if test "$(top_builddir)x" != "$(top_srcdir)x" -a -e "$(srcdir)/gnurl.1"; then \
+ $(INSTALL_DATA) "$(srcdir)/gnurl.1" $@; fi
cd cmdline-opts && $(MAKE)
-html: $(HTMLPAGES)
- cd libcurl && $(MAKE) html
-
-pdf: $(PDFPAGES)
- cd libcurl && $(MAKE) pdf
-
-.1.html:
- $(MAN2HTML)
-
-.1.pdf:
- @(foo=`echo $@ | sed -e 's/\.[0-9]$$//g'`; \
- groff -Tps -man $< >$$foo.ps; \
- ps2pdf $$foo.ps $@; \
- rm $$foo.ps; \
- echo "converted $< to $@")
-
distclean:
rm -f $(CLEANFILES)