summaryrefslogtreecommitdiff
path: root/docs/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'docs/Makefile.am')
-rw-r--r--docs/Makefile.am7
1 files changed, 5 insertions, 2 deletions
diff --git a/docs/Makefile.am b/docs/Makefile.am
index a1e64b6ad..ee8f60718 100644
--- a/docs/Makefile.am
+++ b/docs/Makefile.am
@@ -5,7 +5,7 @@
# | (__| |_| | _ <| |___
# \___|\___/|_| \_\_____|
#
-# Copyright (C) 1998 - 2016, Daniel Stenberg, <daniel@haxx.se>, et al.
+# Copyright (C) 1998 - 2017, Daniel Stenberg, <daniel@haxx.se>, et al.
#
# This software is licensed as described in the file COPYING, which
# you should have received as part of this distribution. The terms
@@ -31,7 +31,7 @@ HTMLPAGES = $(GENHTMLPAGES) index.html
SUBDIRS = examples libcurl cmdline-opts
-CLEANFILES = $(GENHTMLPAGES) $(PDFPAGES)
+CLEANFILES = $(GENHTMLPAGES) $(PDFPAGES) curl.1
EXTRA_DIST = MANUAL BUGS CONTRIBUTE.md FAQ FEATURES INTERNALS.md SSLCERTS.md \
README.win32 RESOURCES TODO TheArtOfHttpScripting THANKS VERSIONS KNOWN_BUGS \
@@ -44,6 +44,9 @@ MAN2HTML= roffit $< >$@
SUFFIXES = .1 .html .pdf
+curl.1:
+ cd cmdline-opts && make
+
html: $(HTMLPAGES)
cd libcurl && make html