summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rwxr-xr-xconfigure.ac140
1 files changed, 109 insertions, 31 deletions
diff --git a/configure.ac b/configure.ac
index 4cd2cb81f..f14bee011 100755
--- a/configure.ac
+++ b/configure.ac
@@ -24,7 +24,7 @@ dnl Process this file with autoconf to produce a configure script.
AC_PREREQ(2.57)
dnl We don't know the version number "statically" so we use a dash here
-AC_INIT([curl], [-], [a suitable curl mailing list: https://curl.haxx.se/mail/])
+AC_INIT([gnurl], [-], [a suitable curl mailing list: https://curl.haxx.se/mail/])
XC_OVR_ZZ50
XC_OVR_ZZ60
@@ -128,7 +128,7 @@ AC_SUBST([AR])
AC_SUBST(libext)
dnl figure out the libcurl version
-CURLVERSION=`$SED -ne 's/^#define LIBCURL_VERSION "\(.*\)".*/\1/p' ${srcdir}/include/curl/curlver.h`
+CURLVERSION=`$SED -ne 's/^#define LIBCURL_VERSION "\(.*\)".*/\1/p' ${srcdir}/include/gnurl/curlver.h`
XC_CHECK_PROG_CC
dnl for --enable-code-coverage
@@ -142,7 +142,7 @@ AC_SUBST(CURLVERSION)
dnl
dnl we extract the numerical version for curl-config only
-VERSIONNUM=`$SED -ne 's/^#define LIBCURL_VERSION_NUM 0x\([0-9A-Fa-f]*\).*/\1/p' ${srcdir}/include/curl/curlver.h`
+VERSIONNUM=`$SED -ne 's/^#define LIBCURL_VERSION_NUM 0x\([0-9A-Fa-f]*\).*/\1/p' ${srcdir}/include/gnurl/curlver.h`
AC_SUBST(VERSIONNUM)
dnl Solaris pkgadd support definitions
@@ -375,6 +375,7 @@ AC_HELP_STRING([--enable-http],[Enable HTTP support])
AC_HELP_STRING([--disable-http],[Disable HTTP support]),
[ case "$enableval" in
no)
+ AC_MSG_ERROR([You must build gnurl with --enable-http!])
AC_MSG_RESULT(no)
AC_DEFINE(CURL_DISABLE_HTTP, 1, [to disable HTTP])
disable_http="yes"
@@ -398,10 +399,15 @@ AC_HELP_STRING([--disable-ftp],[Disable FTP support]),
AC_DEFINE(CURL_DISABLE_FTP, 1, [to disable FTP])
AC_SUBST(CURL_DISABLE_FTP, [1])
;;
- *) AC_MSG_RESULT(yes)
+ *)
+ AC_MSG_ERROR([You must build gnurl with --disable-ftp!])
+ AC_MSG_RESULT(yes)
;;
esac ],
- AC_MSG_RESULT(yes)
+ if test "x$CURL_DISABLE_FTP" != "x1"; then
+ AC_MSG_ERROR([You must build gnurl with --disable-ftp!])
+ fi
+ AC_MSG_RESULT(no)
)
AC_MSG_CHECKING([whether to support file])
AC_ARG_ENABLE(file,
@@ -413,10 +419,15 @@ AC_HELP_STRING([--disable-file],[Disable FILE support]),
AC_DEFINE(CURL_DISABLE_FILE, 1, [to disable FILE])
AC_SUBST(CURL_DISABLE_FILE, [1])
;;
- *) AC_MSG_RESULT(yes)
+ *)
+ AC_MSG_ERROR([You must build gnurl with --disable-file!])
+ AC_MSG_RESULT(no)
;;
esac ],
- AC_MSG_RESULT(yes)
+ if test "x$CURL_DISABLE_FILE" != "x1"; then
+ AC_MSG_ERROR([You must build gnurl with --disable-file!])
+ fi
+ AC_MSG_RESULT(no)
)
AC_MSG_CHECKING([whether to support ldap])
AC_ARG_ENABLE(ldap,
@@ -429,10 +440,14 @@ AC_HELP_STRING([--disable-ldap],[Disable LDAP support]),
AC_SUBST(CURL_DISABLE_LDAP, [1])
;;
*)
+ AC_MSG_ERROR([You must build gnurl with --disable-ldap!])
AC_MSG_RESULT(yes)
;;
esac ],[
- AC_MSG_RESULT(yes) ]
+ if test "x$CURL_DISABLE_LDAP" != "x1"; then
+ AC_MSG_ERROR([You must build gnurl with --disable-ldap!])
+ fi
+ AC_MSG_RESULT(no) ]
)
AC_MSG_CHECKING([whether to support ldaps])
AC_ARG_ENABLE(ldaps,
@@ -479,12 +494,14 @@ AC_HELP_STRING([--disable-rtsp],[Disable RTSP support]),
*) if test x$CURL_DISABLE_HTTP = x1 ; then
AC_MSG_ERROR(HTTP support needs to be enabled in order to enable RTSP support!)
else
+ AC_MSG_ERROR([You must build gnurl with --disable-rtsp!])
AC_MSG_RESULT(yes)
curl_rtsp_msg="enabled"
fi
;;
esac ],
if test "x$CURL_DISABLE_HTTP" != "x1"; then
+ AC_MSG_ERROR([You must build gnurl with --disable-rtsp!])
AC_MSG_RESULT(yes)
curl_rtsp_msg="enabled"
else
@@ -518,10 +535,15 @@ AC_HELP_STRING([--disable-dict],[Disable DICT support]),
AC_DEFINE(CURL_DISABLE_DICT, 1, [to disable DICT])
AC_SUBST(CURL_DISABLE_DICT, [1])
;;
- *) AC_MSG_RESULT(yes)
+ *)
+ AC_MSG_ERROR([You must build gnurl with --disable-dict!])
+ AC_MSG_RESULT(no)
;;
esac ],
- AC_MSG_RESULT(yes)
+ if test "x$CURL_DISABLE_DICT" != "x1"; then
+ AC_MSG_ERROR([You must build gnurl with --disable-dict!])
+ fi
+ AC_MSG_RESULT(no)
)
AC_MSG_CHECKING([whether to support telnet])
AC_ARG_ENABLE(telnet,
@@ -533,9 +555,13 @@ AC_HELP_STRING([--disable-telnet],[Disable TELNET support]),
AC_DEFINE(CURL_DISABLE_TELNET, 1, [to disable TELNET])
AC_SUBST(CURL_DISABLE_TELNET, [1])
;;
- *) AC_MSG_RESULT(yes)
+ *)
+ AC_MSG_ERROR([You must build gnurl with --disable-telnet!])
;;
esac ],
+ if test "x$CURL_DISABLE_TELNET" != "x1"; then
+ AC_MSG_ERROR([You must build gnurl with --disable-telnet!])
+ fi
AC_MSG_RESULT(yes)
)
AC_MSG_CHECKING([whether to support tftp])
@@ -548,9 +574,14 @@ AC_HELP_STRING([--disable-tftp],[Disable TFTP support]),
AC_DEFINE(CURL_DISABLE_TFTP, 1, [to disable TFTP])
AC_SUBST(CURL_DISABLE_TFTP, [1])
;;
- *) AC_MSG_RESULT(yes)
+ *)
+ AC_MSG_ERROR([You must build gnurl with --disable-tftp!])
+ AC_MSG_RESULT(yes)
;;
esac ],
+ if test "x$CURL_DISABLE_TFTP" != "x1"; then
+ AC_MSG_ERROR([You must build gnurl with --disable-tftp!])
+ fi
AC_MSG_RESULT(yes)
)
@@ -564,9 +595,14 @@ AC_HELP_STRING([--disable-pop3],[Disable POP3 support]),
AC_DEFINE(CURL_DISABLE_POP3, 1, [to disable POP3])
AC_SUBST(CURL_DISABLE_POP3, [1])
;;
- *) AC_MSG_RESULT(yes)
+ *)
+ AC_MSG_ERROR([You must build gnurl with --disable-pop3!])
+ AC_MSG_RESULT(yes)
;;
esac ],
+ if test "x$CURL_DISABLE_POP3" != "x1"; then
+ AC_MSG_ERROR([You must build gnurl with --disable-pop3!])
+ fi
AC_MSG_RESULT(yes)
)
@@ -581,9 +617,14 @@ AC_HELP_STRING([--disable-imap],[Disable IMAP support]),
AC_DEFINE(CURL_DISABLE_IMAP, 1, [to disable IMAP])
AC_SUBST(CURL_DISABLE_IMAP, [1])
;;
- *) AC_MSG_RESULT(yes)
+ *)
+ AC_MSG_ERROR([You must build gnurl with --disable-imap!])
+ AC_MSG_RESULT(yes)
;;
esac ],
+ if test "x$CURL_DISABLE_IMAP" != "x1"; then
+ AC_MSG_ERROR([You must build gnurl with --disable-imap!])
+ fi
AC_MSG_RESULT(yes)
)
@@ -598,9 +639,14 @@ AC_HELP_STRING([--disable-smb],[Disable SMB/CIFS support]),
AC_DEFINE(CURL_DISABLE_SMB, 1, [to disable SMB/CIFS])
AC_SUBST(CURL_DISABLE_SMB, [1])
;;
- *) AC_MSG_RESULT(yes)
+ *)
+ AC_MSG_ERROR([You must build gnurl with --disable-smb!])
+ AC_MSG_RESULT(yes)
;;
esac ],
+ if test "x$CURL_DISABLE_SMB" != "x1"; then
+ AC_MSG_ERROR([You must build gnurl with --disable-smb!])
+ fi
AC_MSG_RESULT(yes)
)
@@ -614,9 +660,14 @@ AC_HELP_STRING([--disable-smtp],[Disable SMTP support]),
AC_DEFINE(CURL_DISABLE_SMTP, 1, [to disable SMTP])
AC_SUBST(CURL_DISABLE_SMTP, [1])
;;
- *) AC_MSG_RESULT(yes)
+ *)
+ AC_MSG_ERROR([You must build gnurl with --disable-smtp!])
+ AC_MSG_RESULT(yes)
;;
esac ],
+ if test "x$CURL_DISABLE_SMTP" != "x1"; then
+ AC_MSG_ERROR([You must build gnurl with --disable-smtp!])
+ fi
AC_MSG_RESULT(yes)
)
@@ -630,9 +681,14 @@ AC_HELP_STRING([--disable-gopher],[Disable Gopher support]),
AC_DEFINE(CURL_DISABLE_GOPHER, 1, [to disable Gopher])
AC_SUBST(CURL_DISABLE_GOPHER, [1])
;;
- *) AC_MSG_RESULT(yes)
+ *)
+ AC_MSG_ERROR([You must build gnurl with --disable-gopher!])
+ AC_MSG_RESULT(yes)
;;
esac ],
+ if test "x$CURL_DISABLE_GOPHER" != "x1"; then
+ AC_MSG_ERROR([You must build gnurl with --disable-gopher!])
+ fi
AC_MSG_RESULT(yes)
)
@@ -649,12 +705,12 @@ AC_HELP_STRING([--disable-manual],[Disable built-in manual]),
no)
AC_MSG_RESULT(no)
;;
- *) AC_MSG_RESULT(yes)
- USE_MANUAL="1"
+ *) AC_MSG_RESULT(no)
+ USE_MANUAL="0"
;;
esac ],
- AC_MSG_RESULT(yes)
- USE_MANUAL="1"
+ AC_MSG_RESULT(no)
+ USE_MANUAL="0"
)
dnl The actual use of the USE_MANUAL variable is done much later in this
dnl script to allow other actions to disable it as well.
@@ -1323,6 +1379,7 @@ AC_ARG_WITH(gssapi,
save_CPPFLAGS="$CPPFLAGS"
AC_MSG_CHECKING([if GSS-API support is requested])
if test x"$want_gss" = xyes; then
+ AC_MSG_ERROR([You must build gnurl with --without-gssapi])
AC_MSG_RESULT(yes)
if test -z "$GSSAPI_INCS"; then
@@ -1400,6 +1457,7 @@ else
AC_MSG_RESULT(no)
fi
if test x"$want_gss" = xyes; then
+ AC_MSG_ERROR([You must build gnurl with --without-gssapi])
AC_DEFINE(HAVE_GSSAPI, 1, [if you have GSS-API libraries])
HAVE_GSSAPI=1
curl_gss_msg="enabled (MIT Kerberos/Heimdal)"
@@ -1633,6 +1691,7 @@ if test -z "$ssl_backends" -o "x$OPT_SSL" != xno &&
case "$OPT_SSL" in
yes)
+ AC_MSG_ERROR([You must not build gnurl with OpenSSL, use --without-ssl!])
dnl --with-ssl (without path) used
if test x$cross_compiling != xyes; then
dnl only do pkg-config magic when not cross-compiling
@@ -1642,6 +1701,7 @@ if test -z "$ssl_backends" -o "x$OPT_SSL" != xno &&
LIB_OPENSSL="$PREFIX_OPENSSL/lib$libsuff"
;;
off)
+ AC_MSG_ERROR([You must not build gnurl with OpenSSL, use --without-ssl!])
dnl no --with-ssl option given, just check default places
if test x$cross_compiling != xyes; then
dnl only do pkg-config magic when not cross-compiling
@@ -1650,6 +1710,7 @@ if test -z "$ssl_backends" -o "x$OPT_SSL" != xno &&
PREFIX_OPENSSL=
;;
*)
+ AC_MSG_ERROR([You must not build gnurl with OpenSSL, use --without-ssl!])
dnl check the given --with-ssl spot
PKGTEST="no"
PREFIX_OPENSSL=$OPT_SSL
@@ -1825,6 +1886,7 @@ if test -z "$ssl_backends" -o "x$OPT_SSL" != xno &&
fi
if test X"$OPENSSL_ENABLED" = X"1"; then
+ AC_MSG_ERROR([You must not build gnurl with OpenSSL, use --without-ssl!])
dnl These can only exist if OpenSSL exists
dnl Older versions of Cyassl (some time before 2.9.4) don't have
dnl SSL_get_shutdown (but this check won't actually detect it there
@@ -1963,7 +2025,7 @@ dnl check for GnuTLS
dnl ----------------------------------------------------
dnl Default to compiler & linker defaults for GnuTLS files & libraries.
-OPT_GNUTLS=no
+OPT_GNUTLS=yes
AC_ARG_WITH(gnutls,dnl
AC_HELP_STRING([--with-gnutls=PATH],[where to look for GnuTLS, PATH points to the installation root])
@@ -2663,6 +2725,7 @@ AC_ARG_WITH(libpsl,
with_libpsl=$withval,
with_libpsl=yes)
if test $with_libpsl != "no"; then
+ AC_MSG_ERROR([You must build gnurl with --without-libpsl!])
AC_SEARCH_LIBS(psl_builtin, psl,
[curl_psl_msg="enabled";
AC_DEFINE([USE_LIBPSL], [1], [PSL support enabled])
@@ -2693,6 +2756,7 @@ if test X"$OPT_LIBMETALINK" != Xno; then
version=""
libmetalinklib=""
+ AC_MSG_ERROR([You must build gnurl with --without-libmetalink!])
PKGTEST="no"
if test "x$OPT_LIBMETALINK" = "xyes"; then
dnl this is with no partiular path given
@@ -2788,6 +2852,7 @@ if test X"$OPT_LIBSSH2" != Xno; then
case "$OPT_LIBSSH2" in
yes)
+ AC_MSG_ERROR([You must build gnurl with --without-libssh!])
dnl --with-libssh2 (without path) used
CURL_CHECK_PKGCONFIG(libssh2)
@@ -2861,6 +2926,7 @@ elif test X"$OPT_LIBSSH" != Xno; then
case "$OPT_LIBSSH" in
yes)
+ AC_MSG_ERROR([You must build gnurl with --without-libssh!])
dnl --with-libssh (without path) used
CURL_CHECK_PKGCONFIG(libssh)
@@ -2877,6 +2943,7 @@ elif test X"$OPT_LIBSSH" != Xno; then
dnl no --with-libssh option given, just check default places
;;
*)
+ AC_MSG_ERROR([You must build gnurl with --without-libssh!])
dnl use the given --with-libssh spot
PREFIX_SSH=$OPT_LIBSSH
;;
@@ -2947,6 +3014,7 @@ if test X"$OPT_LIBRTMP" != Xno; then
case "$OPT_LIBRTMP" in
yes)
+ AC_MSG_ERROR([You must build gnurl with --without-librtmp!])
dnl --with-librtmp (without path) used
CURL_CHECK_PKGCONFIG(librtmp)
@@ -2964,16 +3032,18 @@ if test X"$OPT_LIBRTMP" != Xno; then
;;
off)
+ AC_MSG_ERROR([You must build gnurl with --without-librtmp!])
dnl no --with-librtmp option given, just check default places
LIB_RTMP="-lrtmp"
;;
*)
+ AC_MSG_ERROR([You must build gnurl with --without-librtmp!])
dnl use the given --with-librtmp spot
LIB_RTMP="-lrtmp"
PREFIX_RTMP=$OPT_LIBRTMP
;;
esac
-
+ AC_MSG_ERROR([You must build gnurl with --without-librtmp!])
dnl if given with a prefix, we set -L and -I based on that
if test -n "$PREFIX_RTMP"; then
LD_RTMP=-L${PREFIX_RTMP}/lib$libsuff
@@ -3271,7 +3341,7 @@ dnl **********************************************************************
dnl Check for nghttp2
dnl **********************************************************************
-OPT_H2="yes"
+OPT_H2="no"
if test "x$disable_http" = "xyes"; then
# without HTTP, nghttp2 is no use
@@ -3288,11 +3358,13 @@ case "$OPT_H2" in
want_h2="no"
;;
yes)
+ AC_MSG_ERROR([You must build gnurl with --without-nghttp2!])
dnl --with-nghttp2 option used without path
want_h2="default"
want_h2_path=""
;;
*)
+ AC_MSG_ERROR([You must build gnurl with --without-nghttp2!])
dnl --with-nghttp2 option used with path
want_h2="yes"
want_h2_path="$withval/lib/pkgconfig"
@@ -3512,7 +3584,7 @@ AX_COMPILE_CHECK_SIZEOF(off_t)
o=$CPPFLAGS
CPPFLAGS="-I$srcdir/include $CPPFLAGS"
AX_COMPILE_CHECK_SIZEOF(curl_off_t, [
-#include <curl/system.h>
+#include <gnurl/system.h>
])
CPPFLAGS=$o
@@ -3729,6 +3801,13 @@ AC_PATH_PROG( PERL, perl, ,
$PATH:/usr/local/bin/perl:/usr/bin/:/usr/local/bin )
AC_SUBST(PERL)
+# autotools' m4 for python has no maximum version!
+# python3.4 - python3.7 for tests
+m4_define_default([_AM_PYTHON_INTERPRETER_LIST],[python2.7 python3 python3.4 python3.5 python3.6 python3.7 python])
+AM_PATH_PYTHON([2.7],, [:])
+AC_SUBST([PYTHON])
+AM_CONDITIONAL([HAVE_PYTHON], [test "$PYTHON" != :])
+
AC_PATH_PROGS( NROFF, gnroff nroff, ,
$PATH:/usr/bin/:/usr/local/bin )
AC_SUBST(NROFF)
@@ -3760,7 +3839,7 @@ then
dnl if no nroff tool was found, or no option that could convert man pages
dnl was found, then disable the built-in manual stuff
AC_MSG_WARN([disabling built-in manual])
- USE_MANUAL="no";
+ USE_MANUAL="yes";
fi
dnl *************************************************************************
@@ -4299,9 +4378,8 @@ AC_CONFIG_FILES([Makefile \
docs/examples/Makefile \
docs/libcurl/Makefile \
docs/libcurl/opts/Makefile \
- docs/cmdline-opts/Makefile \
include/Makefile \
- include/curl/Makefile \
+ include/gnurl/Makefile \
src/Makefile \
lib/Makefile \
scripts/Makefile \
@@ -4315,8 +4393,8 @@ AC_CONFIG_FILES([Makefile \
tests/unit/Makefile \
packages/Makefile \
packages/vms/Makefile \
- curl-config \
- libcurl.pc
+ gnurl-config \
+ libgnurl.pc
])
AC_OUTPUT
@@ -4324,7 +4402,7 @@ CURL_GENERATE_CONFIGUREHELP_PM
XC_AMEND_DISTCLEAN([lib src tests/unit tests/server tests/libtest docs/examples])
-AC_MSG_NOTICE([Configured to build curl/libcurl:
+AC_MSG_NOTICE([Configured to build gnurl/libgnurl:
Host setup: ${host}
Install prefix: ${prefix}