summaryrefslogtreecommitdiff
path: root/tests/server/CMakeLists.txt
diff options
context:
space:
mode:
authorBill Hoffman <bill.hoffman@kitware.com>2009-07-14 19:03:31 +0000
committerBill Hoffman <bill.hoffman@kitware.com>2009-07-14 19:03:31 +0000
commita8ea1e9ef4ec959cfe95193318a05688f4610841 (patch)
treec336fdf5cb277cad0bb61adda2e42ac61da551a9 /tests/server/CMakeLists.txt
parent6dade671adac2a02f1a5d68046e844967a4e639b (diff)
downloadgnurl-a8ea1e9ef4ec959cfe95193318a05688f4610841.tar.gz
gnurl-a8ea1e9ef4ec959cfe95193318a05688f4610841.tar.bz2
gnurl-a8ea1e9ef4ec959cfe95193318a05688f4610841.zip
ENH: add optional support for c-ares
Diffstat (limited to 'tests/server/CMakeLists.txt')
-rw-r--r--tests/server/CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/tests/server/CMakeLists.txt b/tests/server/CMakeLists.txt
index 01db82401..99ec3d897 100644
--- a/tests/server/CMakeLists.txt
+++ b/tests/server/CMakeLists.txt
@@ -9,7 +9,10 @@ function(SETUP_EXECUTABLE TEST_NAME) # ARGN are the files in the test
${CURL_BINARY_DIR}/lib # To be able to reach "curl_config.h"
${CURL_BINARY_DIR}/include # To be able to reach "curl/curlbuild.h"
)
-
+ if(CURL_USE_ARES)
+ include_directories(${CARES_INCLUDE_DIR})
+ endif()
+ # resolve test needs this
setup_curl_dependencies(${TEST_NAME})
#TARGET_LINK_LIBRARIES( ${TEST_NAME} libcurl )