summaryrefslogtreecommitdiff
path: root/tests/server/CMakeLists.txt
diff options
context:
space:
mode:
authorMarcel Raad <Marcel.Raad@teamviewer.com>2017-07-18 18:46:53 +0200
committerMarcel Raad <Marcel.Raad@teamviewer.com>2017-08-03 08:39:23 +0200
commit866e02935deb28373130116dac578d84e057a03e (patch)
tree037c9675884a4fd631c2d1df58161b3deedc2d6c /tests/server/CMakeLists.txt
parent70934885d0ed23c83a01efc70034f811d20a33e6 (diff)
downloadgnurl-866e02935deb28373130116dac578d84e057a03e.tar.gz
gnurl-866e02935deb28373130116dac578d84e057a03e.tar.bz2
gnurl-866e02935deb28373130116dac578d84e057a03e.zip
CMake: set MSVC warning level to 4
The MSVC warning level defaults to 3 in CMake. Change it to 4, which is consistent with the Visual Studio and NMake builds. Disable level 4 warning C4127 for the library and additionally C4306 for the test servers to get a clean CURL_WERROR build as that warning is raised in some macros in older Visual Studio versions. Ref: https://github.com/curl/curl/pull/1667#issuecomment-314082794 Closes https://github.com/curl/curl/pull/1711
Diffstat (limited to 'tests/server/CMakeLists.txt')
-rw-r--r--tests/server/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/tests/server/CMakeLists.txt b/tests/server/CMakeLists.txt
index e456a94df..cfc1434cd 100644
--- a/tests/server/CMakeLists.txt
+++ b/tests/server/CMakeLists.txt
@@ -1,5 +1,9 @@
set(TARGET_LABEL_PREFIX "Test server ")
+if(MSVC)
+ set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} /wd4127 /wd4306")
+endif()
+
function(SETUP_EXECUTABLE TEST_NAME) # ARGN are the files in the test
add_executable( ${TEST_NAME} ${ARGN} )
string(TOUPPER ${TEST_NAME} UPPER_TEST_NAME)