summaryrefslogtreecommitdiff
path: root/tests/server/CMakeLists.txt
diff options
context:
space:
mode:
authorSergei Nikulov <sergey.nikulov@gmail.com>2013-07-09 19:20:41 +0400
committerDaniel Stenberg <daniel@haxx.se>2013-07-17 00:26:58 +0200
commit448d55ef0a2d6a0d8a18778f6d6a6a432d05bbb6 (patch)
tree8584320def19a2624259c29dd22141c6dc3391c9 /tests/server/CMakeLists.txt
parent7b115cc1e16435b35d5b3bd8d3ca205c18438ecc (diff)
downloadgnurl-448d55ef0a2d6a0d8a18778f6d6a6a432d05bbb6.tar.gz
gnurl-448d55ef0a2d6a0d8a18778f6d6a6a432d05bbb6.tar.bz2
gnurl-448d55ef0a2d6a0d8a18778f6d6a6a432d05bbb6.zip
cmake: Fix for MSVC2010 project generation
Fixed issue with static build for MSVC2010. After some investigation I've discovered known issue http://public.kitware.com/Bug/view.php?id=11240 When .rc file is linked to static lib it fails with following linker error LINK : warning LNK4068: /MACHINE not specified; defaulting to X86 file.obj : fatal error LNK1112: module machine type 'x64' conflicts with target machine type 'X86' Fix add target property /MACHINE: for MSVC generation. Also removed old workarounds - it caused errors during msvc build. Bug: http://curl.haxx.se/mail/lib-2013-07/0046.html
Diffstat (limited to 'tests/server/CMakeLists.txt')
-rw-r--r--tests/server/CMakeLists.txt8
1 files changed, 0 insertions, 8 deletions
diff --git a/tests/server/CMakeLists.txt b/tests/server/CMakeLists.txt
index cc5b3e044..ee08345f8 100644
--- a/tests/server/CMakeLists.txt
+++ b/tests/server/CMakeLists.txt
@@ -33,14 +33,6 @@ function(SETUP_EXECUTABLE TEST_NAME) # ARGN are the files in the test
set_target_properties(${TEST_NAME} PROPERTIES
DEBUG_POSTFIX "${CMAKE_DEBUG_POSTFIX}")
- if(MSVC)
- if(NOT BUILD_RELEASE_DEBUG_DIRS)
- # Ugly workaround to remove the "/debug" or "/release" in each output
- set_target_properties(${TEST_NAME} PROPERTIES PREFIX "../")
- set_target_properties(${TEST_NAME} PROPERTIES IMPORT_PREFIX "../")
- endif()
- endif()
-
endfunction()