summaryrefslogtreecommitdiff
path: root/tests/libtest/Makefile.am
diff options
context:
space:
mode:
authorYang Tse <yangsita@gmail.com>2010-08-09 09:33:53 +0200
committerYang Tse <yangsita@gmail.com>2010-08-09 09:33:53 +0200
commitb24e87250241c97c23f7c71c0ab9de74e793b8cc (patch)
tree61adeb49f2cfb35d150a54da7527c18d4c25e552 /tests/libtest/Makefile.am
parent50a1d5ee1c127d76ea3316f86d53accb66bc0b22 (diff)
downloadgnurl-b24e87250241c97c23f7c71c0ab9de74e793b8cc.tar.gz
gnurl-b24e87250241c97c23f7c71c0ab9de74e793b8cc.tar.bz2
gnurl-b24e87250241c97c23f7c71c0ab9de74e793b8cc.zip
build: don't build libhostname unless shared libcurl is built
Diffstat (limited to 'tests/libtest/Makefile.am')
-rw-r--r--tests/libtest/Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/tests/libtest/Makefile.am b/tests/libtest/Makefile.am
index 0603c03e1..2ba7b0a32 100644
--- a/tests/libtest/Makefile.am
+++ b/tests/libtest/Makefile.am
@@ -64,7 +64,11 @@ include Makefile.inc
# Preloading of libhostname allows host name overriding,
# this is used to make some tests machine independent.
+if BUILD_LIBHOSTNAME
noinst_LTLIBRARIES = libhostname.la
+else
+noinst_LTLIBRARIES =
+endif
if NO_UNDEFINED
# The -no-undefined flag is crucial to build fine on some platforms