summaryrefslogtreecommitdiff
path: root/tests/libtest/Makefile.am
diff options
context:
space:
mode:
authorYang Tse <yangsita@gmail.com>2012-04-11 19:33:54 +0200
committerYang Tse <yangsita@gmail.com>2012-04-11 19:33:54 +0200
commit9e24b9c7afbcb81120af4cf3f6cdee49a06d8224 (patch)
tree0c671c32f59daa6848636e7f34c6071ed2bcae37 /tests/libtest/Makefile.am
parenta144bb8b767b1c9ae40a0e7853db88ed67c9e8c3 (diff)
downloadgnurl-9e24b9c7afbcb81120af4cf3f6cdee49a06d8224.tar.gz
gnurl-9e24b9c7afbcb81120af4cf3f6cdee49a06d8224.tar.bz2
gnurl-9e24b9c7afbcb81120af4cf3f6cdee49a06d8224.zip
build adjustments: CURL_HIDDEN_SYMBOLS no longer defined in config files
configure script now provides conditional definitions for Makefile.am that result in CURL_HIDDEN_SYMBOLS being defined by resulting makefiles when appropriate. Additionally, configure script option for symbol hiding control is now named --enable-symbol-hiding --disable-symbol-hiding. While still valid, old option name --enable-hidden-symbols --disable-hidden-symbols will be deprecated in some future release.
Diffstat (limited to 'tests/libtest/Makefile.am')
-rw-r--r--tests/libtest/Makefile.am9
1 files changed, 9 insertions, 0 deletions
diff --git a/tests/libtest/Makefile.am b/tests/libtest/Makefile.am
index be667ee22..e4538b750 100644
--- a/tests/libtest/Makefile.am
+++ b/tests/libtest/Makefile.am
@@ -53,6 +53,8 @@ endif
EXTRA_DIST = test75.pl test307.pl test610.pl test613.pl test1013.pl \
test1022.pl Makefile.inc
+CFLAG_SYMBOL_HIDING = @CFLAG_SYMBOL_HIDING@
+
# Dependencies (may need to be overriden)
LDADD = $(top_builddir)/lib/libcurl.la @CURL_LIBS@
DEPENDENCIES = $(top_builddir)/lib/libcurl.la
@@ -86,3 +88,10 @@ libhostname_la_LIBADD =
libhostname_la_DEPENDENCIES =
libhostname_la_LDFLAGS = -module -avoid-version $(UNDEF) -rpath /nowhere
+if DOING_SYMBOL_HIDING
+libhostname_la_CPPFLAGS = $(AM_CPPFLAGS) -DCURL_HIDDEN_SYMBOLS
+libhostname_la_CFLAGS = $(AM_CFLAGS) $(CFLAG_SYMBOL_HIDING)
+else
+libhostname_la_CPPFLAGS = $(AM_CPPFLAGS)
+libhostname_la_CFLAGS = $(AM_CFLAGS)
+endif