aboutsummaryrefslogtreecommitdiff
path: root/tests/libtest/Makefile.am
diff options
context:
space:
mode:
authorYang Tse <yangsita@gmail.com>2012-04-09 21:24:16 +0200
committerYang Tse <yangsita@gmail.com>2012-04-09 21:24:16 +0200
commit21423497efe36c70615d0a54e040f76043823345 (patch)
tree28baa5aa512f4352ef7a0dfd34bd6fc7c6f8d7b3 /tests/libtest/Makefile.am
parent01b0f1061da2bd7a8703f4c8aa846a9088d7ab3e (diff)
downloadgnurl-21423497efe36c70615d0a54e040f76043823345.tar.gz
gnurl-21423497efe36c70615d0a54e040f76043823345.tar.bz2
gnurl-21423497efe36c70615d0a54e040f76043823345.zip
configure: Windows cross-compilation fixes
BUILDING_LIBCURL and CURL_STATICLIB are no longer defined in curl_config.h, configure will generate appropriate conditionals so that mentioned symbols get defined and used in Makefiles at compilation time
Diffstat (limited to 'tests/libtest/Makefile.am')
-rw-r--r--tests/libtest/Makefile.am7
1 files changed, 6 insertions, 1 deletions
diff --git a/tests/libtest/Makefile.am b/tests/libtest/Makefile.am
index 9c0d59507..be667ee22 100644
--- a/tests/libtest/Makefile.am
+++ b/tests/libtest/Makefile.am
@@ -5,7 +5,7 @@
# | (__| |_| | _ <| |___
# \___|\___/|_| \_\_____|
#
-# Copyright (C) 1998 - 2010, Daniel Stenberg, <daniel@haxx.se>, et al.
+# Copyright (C) 1998 - 2012, Daniel Stenberg, <daniel@haxx.se>, et al.
#
# This software is licensed as described in the file COPYING, which
# you should have received as part of this distribution. The terms
@@ -57,6 +57,11 @@ test1022.pl Makefile.inc
LDADD = $(top_builddir)/lib/libcurl.la @CURL_LIBS@
DEPENDENCIES = $(top_builddir)/lib/libcurl.la
+# Mostly for Windows build targets, when using static libcurl
+if USE_CPPFLAG_CURL_STATICLIB
+AM_CPPFLAGS = -DCURL_STATICLIB
+endif
+
# Makefile.inc provides the source defines (TESTUTIL, SUPPORTFILES,
# noinst_PROGRAMS, lib*_SOURCES, and lib*_CFLAGS)
include Makefile.inc