aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorDaniel Stenberg <daniel@haxx.se>2011-04-25 22:44:39 +0200
committerDaniel Stenberg <daniel@haxx.se>2011-04-27 09:09:35 +0200
commitaa87f0ab15c15784c4d7ee55e8c5972f5353b41e (patch)
tree822a24e4c999d30e3c9f75d0bc78a8721a174336 /src/Makefile.am
parent6a6981503e509a2bfcec0763535c0f667e23ce38 (diff)
downloadgnurl-aa87f0ab15c15784c4d7ee55e8c5972f5353b41e.tar.gz
gnurl-aa87f0ab15c15784c4d7ee55e8c5972f5353b41e.tar.bz2
gnurl-aa87f0ab15c15784c4d7ee55e8c5972f5353b41e.zip
checksrc: whitespace and code style cleanup
Make everything adhere to the standards upheld by checksrc.pl and now run checksrc from the makefile on debug builds.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am10
1 files changed, 9 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 8b3c0b6b2..c1915f7f7 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -5,7 +5,7 @@
# | (__| |_| | _ <| |___
# \___|\___/|_| \_\_____|
#
-# Copyright (C) 1998 - 2009, Daniel Stenberg, <daniel@haxx.se>, et al.
+# Copyright (C) 1998 - 2011, Daniel Stenberg, <daniel@haxx.se>, et al.
#
# This software is licensed as described in the file COPYING, which
# you should have received as part of this distribution. The terms
@@ -95,3 +95,11 @@ $(HUGE):
echo '#include "hugehelp.h"' >> $(HUGE)
echo "void hugehelp(void) {}" >>$(HUGE)
endif
+
+if CURLDEBUG
+# for debug builds, we scan the sources on all regular make invokes
+# ignore hugehelp.c since it is generated source code and it plays by slightly
+# different rules!
+all-local:
+ @@PERL@ $(top_srcdir)/lib/checksrc.pl -D$(top_srcdir)/src -Whugehelp.c $(curl_SOURCES)
+endif