aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorDave Reisner <dreisner@archlinux.org>2012-10-10 10:05:02 +0200
committerDaniel Stenberg <daniel@haxx.se>2012-11-06 00:32:21 +0100
commit550e403f0023e1ca6c50a658e2d994e7f89d576b (patch)
treef4caedcfe3bba379f94f49feeed3585fa1930dc5 /src/Makefile.am
parentf99430d89ecccf2a899a743d6c856102e967e32a (diff)
downloadgnurl-550e403f0023e1ca6c50a658e2d994e7f89d576b.tar.gz
gnurl-550e403f0023e1ca6c50a658e2d994e7f89d576b.tar.bz2
gnurl-550e403f0023e1ca6c50a658e2d994e7f89d576b.zip
uniformly use AM_CPPFLAGS, avoid deprecated INCLUDES
Since automake 1.12.4, the warnings are issued on running automake: warning: 'INCLUDES' is the old name for 'AM_CPPFLAGS' (or '*_CPPFLAGS') Avoid INCLUDES and roll these flags into AM_CPPFLAGS. Compile tested on: Ubuntu 10.04 (automake 1:1.11.1-1) Ubuntu 12.04 (automake 1:1.11.3-1ubuntu2) Arch Linux (automake 1.12.4)
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am16
1 files changed, 8 insertions, 8 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 6e8ce38a1..b53127d27 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -34,19 +34,19 @@ AUTOMAKE_OPTIONS = foreign nostdinc
# $(top_srcdir)/lib is for libcurl's lib/setup.h and other "borrowed" files
# $(top_srcdir)/src is for curl's src/tool_setup.h and "curl-private" files
-INCLUDES = -I$(top_builddir)/include/curl \
- -I$(top_builddir)/include \
- -I$(top_srcdir)/include \
- -I$(top_builddir)/lib \
- -I$(top_builddir)/src \
- -I$(top_srcdir)/lib \
- -I$(top_srcdir)/src
+AM_CPPFLAGS = -I$(top_builddir)/include/curl \
+ -I$(top_builddir)/include \
+ -I$(top_srcdir)/include \
+ -I$(top_builddir)/lib \
+ -I$(top_builddir)/src \
+ -I$(top_srcdir)/lib \
+ -I$(top_srcdir)/src
bin_PROGRAMS = curl
# Mostly for Windows build targets, when using static libcurl
if USE_CPPFLAG_CURL_STATICLIB
-AM_CPPFLAGS = -DCURL_STATICLIB
+AM_CPPFLAGS += -DCURL_STATICLIB
endif
include Makefile.inc