summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorYang Tse <yangsita@gmail.com>2012-04-09 21:24:16 +0200
committerYang Tse <yangsita@gmail.com>2012-04-09 21:24:16 +0200
commit21423497efe36c70615d0a54e040f76043823345 (patch)
tree28baa5aa512f4352ef7a0dfd34bd6fc7c6f8d7b3 /src/Makefile.am
parent01b0f1061da2bd7a8703f4c8aa846a9088d7ab3e (diff)
downloadgnurl-21423497efe36c70615d0a54e040f76043823345.tar.gz
gnurl-21423497efe36c70615d0a54e040f76043823345.tar.bz2
gnurl-21423497efe36c70615d0a54e040f76043823345.zip
configure: Windows cross-compilation fixes
BUILDING_LIBCURL and CURL_STATICLIB are no longer defined in curl_config.h, configure will generate appropriate conditionals so that mentioned symbols get defined and used in Makefiles at compilation time
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 3e372422f..fb16192e3 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -44,6 +44,11 @@ INCLUDES = -I$(top_builddir)/include/curl \
bin_PROGRAMS = curl
+# Mostly for Windows build targets, when using static libcurl
+if USE_CPPFLAG_CURL_STATICLIB
+AM_CPPFLAGS = -DCURL_STATICLIB
+endif
+
include Makefile.inc
# This might hold -Werror