aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorYang Tse <yangsita@gmail.com>2009-05-30 15:56:42 +0000
committerYang Tse <yangsita@gmail.com>2009-05-30 15:56:42 +0000
commitcd5e6743f744503f357b0877d6b5bad96ae53d1f (patch)
treef3563d2fa9a6a0f4510f271e402e9fc276fe2f05 /src/Makefile.am
parent2091fe530f7609830d96fd4eb3c45e341d1eeb8f (diff)
downloadgnurl-cd5e6743f744503f357b0877d6b5bad96ae53d1f.tar.gz
gnurl-cd5e6743f744503f357b0877d6b5bad96ae53d1f.tar.bz2
gnurl-cd5e6743f744503f357b0877d6b5bad96ae53d1f.zip
Delegate c-ares linking magic on libtool and auto-makefiles when using
the uninstalled c-ares libtool archive built from the CVS embedded tree.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am10
1 files changed, 8 insertions, 2 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index a008dcb1c..b76aad104 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -45,8 +45,14 @@ bin_PROGRAMS = curl
include Makefile.inc
-curl_LDADD = ../lib/libcurl.la @CURL_LIBS@
-curl_DEPENDENCIES = ../lib/libcurl.la
+if USE_EMBEDDED_ARES
+EMBEDDEDARES = ../ares/libcares.la
+else
+EMBEDDEDARES =
+endif
+
+curl_LDADD = ../lib/libcurl.la $(EMBEDDEDARES) @CURL_LIBS@
+curl_DEPENDENCIES = ../lib/libcurl.la $(EMBEDDEDARES)
BUILT_SOURCES = hugehelp.c
CLEANFILES = hugehelp.c
# Use the C locale to ensure that only ASCII characters appear in the